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Introduction

TinkerPlots™ Dynamic Data Exploration is a data analysis program designed specifically for use
by students in grades 4-8. With it, students can enter data they collect themselves or find on the
Internet and can create their own graphs or tables of these data. They can also use TinkerPlots to
produce reports that include these graphs, along with text that explains their findings and even
photos they take or locate on the Internet.

What makes TinkerPlots different from any other “graphing” or spreadsheet program is that,
with TinkerPlots, students actually design their own graphs. This gives them a sense of being in
control of what they produce.

Like a word-processing or spreadsheet program, TinkerPlots is a general tool that teachers and
students alike will find useful across a large range of subject matter. It comes with a variety of
ready-to-analyze data collections, drawn from topics including mathematics, science, history,
geography, health studies, sports, and more.

TinkerPlots Help is a look-up guide, not a tutorial. It answers your questions about how to use
TinkerPlots to accomplish specific tasks. The best first introduction to TinkerPlots is a five-
minute movie called 7inkerPlots Basics. You can view this movie by choosing TinkerPlots Movies
from the Help menu and then TinkerPlots Basics from the Movies page. After you've watched this
short introduction, you'll be ready to use TinkerPlots for most basic tasks. The Movies page also
contains several other short movies that cover various topics in more depth. But we’d
recommend viewing these after you've had a chance to use the program for a while. You'll also
find that you can discover many capabilities by just trying things out on your own.

We also recommend that you read the section TinkerPlots Terms. Some of these terms, such as
fully separated attribute, are unique to TinkerPlots.

The Relationship of TinkerPlots to Fathom

TinkerPlots shares many features with the software package Fathom Dynamic Data™. Fathom
is a data analysis program designed for high school and introductory college courses. Those of
you who are familiar with Fathom will recognize many features the two programs share. The case
table in TinkerPlots is, in fact, nearly identical with Fathom’s case table. Text boxes, sliders, and
the formula editor are also objects that TinkerPlots and Fathom have in common. Functions
such as printing, exporting, and saving are all Fathom routines used by TinkerPlots.

TinkerPlots Help
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TinkerPlots Terms

Collection

A collection is a set of data about several cases. For example, the collection Cats.tp, which comes
with TinkerPlots, contains information on 24 cats.

Case

A case is the basic unit of a data set or collection. For example, in a collection of cats, each cat is a
case. In a collection about different countries of the world, each country is a case. Information
about each case is recorded on one card in the data cards. Each case also has a case icon in a

TinkerPlots plot.

Attribute

Cases have astributes (also known as variables). For example, a collection about cats might
include, for each cat, the attributes Gender, Length, and Fur_Color. Attribute names for a
collection are listed on the left side of each data card.

Value

Each case has a value for each attribute. A particular cat might have the values “Male” for Gender,
“217 for Length, and “Black” for Fur_Color. The value appears directly to the right of the
attribute name in the data cards.

Numeric Attribute

A numeric attribute, such as Length or Age, has numbers for values. You can plot numeric
attributes on a number line and find their mean.

Category Attribute

A category attribute has values that are letters or words. Gender is a category attribute with the
possible values “Male” and “Female.” Fur_Color is also a category attribute with values “Black,”
“White,” “Black_and_White,” and so forth. You can graph category attributes by separating cases
into their different categories. Unlike numeric attributes, you can’t plot category attributes on a
number line or find their mean.

Attribute Color Bar

To the left of each attribute name in the data cards is an a#tribute color bar that shows that
attribute’s color scheme. You can modify an attribute’s color scheme by double-clicking on its
color bar.

Selected Attribute

This is the attribute currently selected in the data cards. When an attribute is selected, a gray
rectangle appears around its name in the data cards, and the case icons in the plot are colored
with that attribute’s color scheme.

Plot Color

When you select an attribute in the data cards, the case icons in the plot take on that attribute’s
color scheme. For numeric attributes such as Age, the case icons are colored with a
gradient—different shades of red, for example. The cases with the largest values have the darkest

TinkerPlots Help
© 2005 University of Massachusetts

10



hue (dark red, for example), while cases with the smallest values are near white. For category
attributes, case icons with different values are colored with distinct hues, such as red, green, and

purple.

Bins

Bins are divisions in plots that contain all cases of a certain type. Bins are separated by light-gray
bin lines. You might want to have “males” and “females” in separate bins, for example. For a
numeric attribute such as Age, you might place people 16-23 years old in one bin, 24-31 in the
next, 32-39 in the next, and so on.

rmale

Gender

fernale

% QOooD | O ]

16-23 24-Z1 I3Z2-Z9 40-47 438-55 SE-63 &d-T71
Age (years)

Fully Separated Attribute

When in a plot you separate an attribute into as many bins as possible, the attribute is fully
separated. When a numeric attribute such as Age is fully separated, the axis appears as a
continuous number line and there are no visible bin lines.

rale

LODOLOD0DiR]

] ookl ol o

0
v
!
a
[\

Gender

female

oo

Age (years)

Excluded Cases

Often a case will be missing a value for one attribute. A cat’s age, for example, might have been
left blank because it was a stray and no one knew its age. In this instance, when the attribute Age
is selected, the case icon for that cat will be colored gray. If you put Age on a plot axis, the case’s
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icon will move to the right side of the plot window into the excluded cases stack. Also, suppose
you wanted your graph to show only those cats that were 2 years and older. You could set the
minimum value of the Age axis at 2, which would cause all cats younger than 2 to move into the
excluded cases stack.

Case Icon Type

There are several case icon types you can choose for a TinkerPlots graph, including circle (the
default), square, value bar, and fuse rectangular. The image icon type allows you to make a graph
with icons resembling cats, for example.

Attribute Formula

You can use an attribute formula to compute the values of an attribute. For example, you could
use a formula to convert heights measured in inches to heights measured in centimeters, or to
divide the attribute /ncome of various countries by the attribute Population to make a new
attribute, Income_per_Person.

TinkerPlots Help
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Getting Started

Here we provide information about installing on multiple computers, getting technical support,
and other basic details.

Install on Multiple Computers

There are two possible configurations for installing a TinkerPlots multi-user edition: Install on
each computer or install on a network server. (The type of license you bought specifies how
many computers you have permission either to install or to run TinkerPlots on.) It is less work to
install and upgrade only on a server, though it will slow performance (by how much will vary
depending on the speed of your computers).

Installation is similar for all: Insert the CD-ROM, double-click the installer, and follow the
instructions on the screen. At the end, you have a choice of restarting or not restarting the
computer.

To Install on Each Computer

Use the TinkerPlots CD-ROM to install TinkerPlots onto each computer for which you are
licensed.

Insert the CD-ROM into a computer’s CD drive, open it, double-click the installer, follow the
instructions on the screen, and restart when you’re through.

Or,

Use the CD-ROM in the server’s CD drive to install onto each machine for which you are
licensed (this is faster than the previous method, because you can install on more than one
machine simultaneously).

Insert the CD-ROM into the server’s CD drive and give sharing privileges for each machine.
From each computer, access the server’s CD drive, double-click the installer, follow the
instructions on the screen, and restart when you’re through.

To Install on the Server

Insert the CD-ROM into the server’s drive, open it, double-click the installer, and follow the
instructions on the screen. At the end, you will be asked whether you want to restart the
computer (your choice).

Make sure the TinkerPlots folder is shared to each computer for which you are licensed, by
whatever method you usually use to share networked software.

You may want to put shortcuts or aliases to TinkerPlots on each networked computer.

Note: All installed sample documents are locked so that students cannot easily save over them.
When students try to save, they will be prompted with a Save As dialog box. They must rename or
move the file in order to complete the save.

Open a Sample Document
TinkerPlots comes with several sample data sets. To open one of these,

1. Open the folder Data and Demos and then one of the subfolders.

2. Double-click one of the TinkerPlots files (these have the suffix .tp).
Or, with TinkerPlots running,

1. Choose Open from the File menu.

2. Locate the folder Data and Demos and then one of the subfolders.

3. Choose the file you want and click Open.

TinkerPlots Help 13
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Get Technical Support

When something goes wrong and you need support, you can

e Check the TinkerPlots Web site at http://www.keypress.com/tinkerplots. You will find
answers to frequently asked questions and the latest updates to the program. You can also
check for updates by choosing Check for Updates from the Help menu.

e Fill out an online technical support form at the TinkerPlots Web site.

e Call our technical support line at Key Curriculum Press, 510-595-7000. We can be most
helpful to you if you are sitting in front of a computer with TinkerPlots running.

Save and Back Up Your Work

No computer system is infallible. Your time is valuable. If you have done a lot of work to enter
data or carry out a brilliant analysis, save your work. Save early. Save often. And then make an
extra copy just in case.

Undo and Redo

TinkerPlots supports (almost) unlimited undo and redo. This means that you can backtrack
several steps to return to a previous plot or state. Choose Undo from the Edit menu or press Ctrl+Z
(Win) Command+Z (Mac) to undo the previous action. Choose Redo to return to the most recently
undone state: Ctrl+R (Win) Command+R (Mac).

TinkerPlots Help
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Working with a Document

A TinkerPlots document is a scrollable page that may contain many different objects that show
different views of the same collection of data, several graphs, for example. Students can use
TinkerPlots not only to analyze data, but also to write a brief report. A report might include
several graphs and even pictures. (For a sample report, see the file Backpack Report.tp in the Data and

Demos | Demos folder.)

There are six different types of objects you can include in a document: data cards, case tables,
plots, sliders, text, and pictures. To learn more about these objects, see TinkerPlots Objects.

Parts of a Document

This figure shows a TinkerPlots document, which includes a plot on the right and a stack of data

cards on the left.
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Create a New Document

Choose New from the File menu.

Place an Object in a Document, Move It, and Resize It

e To place an object in a document, drag the object from the object toolbar (upper-left
corner of the window) and drop it where you want it in the document.

e To move an object, grab the top bar of the object and drag it to a new location.

e To resize an object, grab it by a side, a corner, or by its bottom edge, and drag to the

desired size.
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Duplicate an Object

Duplicating an object is especially useful when you want to make a new graph based on an
existing one (for instance, when you want to create two versions of a graph, one with males only
and one with females only). To duplicate an object,

1. Select the object (click on it).
2. Choose Duplicate Object from the Edit menu.

Iconify an Object and Get It Back Again

If you make an object very small, it will become an icon. This can help save space in your
document. To expand an iconified object, drag a corner or an edge to make it larger.

You can drag icons by their top bars or by their centers.

Catz

-

() caze 4 of 24 4P

[ Attribute  Value Objects can be shrunk
] name Pepper into iconified ohjects.
B ] =ex il

[ age 2

[ weight 12

[ bodyvlength 17
[ taillength 9
W evecolor wellowy
Il padcolor pink
] fur orange

[ Catz | [ Cats |

These are iconified plot
and case table objects.

View an Object in a Separate Window

Sometimes you want to see one object without having to shrink everything else. You can open
that object in its own window, which floats on top of the document.

1. Select the object by clicking on it.
2. Choose View In Window from the Window menu.
The object now exists in its own floating window as well as in the document.

Click the object’s close box when you’re done with it.
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Working with Collections

In TinkerPlots, data sets, or collections, are stored in a stack of data cards. With data cards you
can see one case at time, add or change data, drag attributes into plots, and change the color
scheme of attributes. You can use other objects, namely case tables and plots, to see your data
displayed in other ways.

Open a TinkerPlots Document

TinkerPlots comes with several collections ready to analyze. To open one of these,
1. Double-click a TinkerPlots document (these have the suffix .tp). This will open that
document and, if necessary, start up TinkerPlots.
Or, with TinkerPlots running,
1. Choose Open from the File menu.

2. Navigate to the Data and Demos folder and to one of the subfolders. Choose the document
you want and click Open.

TinkerPlots will also open any Fathom-format files (files with the suffix .ftm). When you open a
Fathom document in TinkerPlots, you won’t be able to see some of the Fathom objects (such as
Fathom graphs), but the data will be there. (To learn more about the relation between Fathom
and TinkerPlots, see The Relationship of TinkerPlots to Fathom.)

Make a New Collection

You can enter your own data into TinkerPlots using either data cards or a case table.

Enter Data into Data Cards

1. Choose New from the File menu to open a new TinkerPlots document.

2. Drag a stack of data cards from the object toolbar into the document. This creates an
empty stack of data cards to hold your data.

3. In the data cards, double-click the cell labeled <new attribute>. Type an attribute name,
then press Enter. A new row will appear below the attribute you just named, where you
can enter your second attribute, and so on.

4. Click in the blank cell to the right of the first attribute you’ve named (in the Value
column). Enter the value of this attribute for the first case.

5. To enter data for the next case (card), click the right arrow in the upper-right corner of
the data cards.

6. Some attributes have units. For example, Height might be measured in units of inches or
centimeters. You can type the names of these units into the Unit column. These units will
be displayed along with their attribute name on plot axes.

7. Save your document as soon as possible.

Enter Data into a Case Table
If you have a lot of data to enter, you’ll find it quicker to enter them into a case table.
1. Choose New from the File menu to open a new TinkerPlots document.

2. Drag a case table from the object toolbar into the document to create an empty case
table. In the case table, attribute names are listed along the top row. Values for case 1 are
listed in the first row below the attribute names, values for case 2 are below those, and so
on.
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3. Click the cell labeled <new> and type an attribute name. Press Enter to move to the cell
below. (Note that when you press Enter TinkerPlots automatically opens a stack of data
cards in the documents.)

no data
tnew> k| -

-
1] [+]

4. In the case table, enter the value of that attribute for case 1, press Enter, enter the value
for case 2, and so on.

5. Repeat steps 3 and 4 to create other attributes and enter their values.
6. Save your document as soon as possible.

Using the previous steps, you enter the data attribute by attribute. Sometimes it is easier to enter
the data case by case, entering all the information for case 1 before going on to case 2, and so on.
To enter data one case at a time in a case table,

1. Enter all the attribute names along the top row.

2. Click in the leftmost cell below the first attribute and enter the value for case 1.

3. Use the Tab key to move along the row for case 1, entering all the data for that case.
4

Press Tab after entering the last value for case 1. This will move you to the first attribute

for case 2. Again, use the Tab key to move along the row and enter all the data for case 2.

Repeat for the other cases.

Import Data

You can quickly import data into TinkerPlots from the Internet or from some other application,
such as spreadsheet software or a word processor. There are three ways to do this: copy and paste
data, import data from a text file, and import data from the Internet.

Copy and Paste Data

1. From within the application that contains the data (a word processor, spreadsheet, Web
page, or whatever), highlight the entire collection and then copy it. Make sure the
attribute names are in the first line you copy and that you copy nothing but the data.

Click in a TinkerPlots document.

3. Create a new stack of data cards and make sure it is selected. (An object is selected when
you can see its frame. Clicking an object will select it.)

4. Choose Paste Cases from the Edit menu.

Import Data from a Text File
1. Create a new TinkerPlots document by choosing New from the File menu.
2. Choose Import From File from the File menu.
3. In the dialog box, select the file you want to import, then click Open.

Or,

1. Drag the text file into a TinkerPlots document. The data will appear in a stack of data
cards.

Note: This method of importing data works only if the file is in text format. If it isn’t in text
format, you’ll first need to open the file from within the program that made it (Microsoft Word

TinkerPlots Help
© 2005 University of Massachusetts

18



or Excel, for example), and then use the Save As command to save the file as a text file.
TinkerPlots is fairly good at recognizing different text file layouts. But the easiest layout for
TinkerPlots to deal with has the names of the attributes in the first line and the values below
them, one line (paragraph) per case, as shown here. The values can be separated by tabs or by
spaces.

SR R

Iare Gender Weight

Faith F 1a7
Tim H 104
Priti F a7

If your data imports, but uses the first case as the attribute names, open the text file in a word-
processing program and add a line at the top with the attribute names. Then import this edited

file.

Import Data from the Internet

1. Find the data you want on the Internet. Be sure you're looking at the page with the data
(not a link to that page).

2. Drag the URL icon from your browser into an open TinkerPlots document. TinkerPlots
will import the data into a new stack of data cards.

2 TinkerPlots - [Document2]

@ File Edt D a Fathom Resource Center:

B | File Edit View Favorites
Cards  Takle S Back v = - @ ﬁf

|| e —— ——————————————
MI@ htkp: e, keypres

Drag the URL icon info TinkerPlots
Or,

1. Choose Import From Url from the TinkerPlots File menu.

2. Type or paste the URL of the data you want into the dialog box and click OK. The data
will appear in a new stack of data cards.

Once the data are in TinkerPlots, check to make sure they imported correctly. The easiest way to
do this is to look at them in a case table. You may need to do a little repair work by editing some
of the data. If there are a lot of problems, it may be easier to export the data into a word
processor or spreadsheet, fix the problems there, then import the data back into TinkerPlots.

e Didn’t get a color gradient for numerical data? Sometimes when you import a collection, a
numeric attribute will appear and behave like a category attribute. That is, its color bar will
show distinct colors rather than a gradient, and when you graph the attribute, it won’t
make a number axis. What is probably going on is that one or more values of the attribute
are characters rather than numbers. Even one case with some text in it will cause the entire
attribute to be treated as a category attribute. To fix this, find and remove the text.

To save information about the data, such as where the data came from and definitions for the
attributes, copy the information from the Web page and paste it into a TinkerPlots text box.
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Export Data

You can export data into spreadsheet software such as Microsoft Excel, statistical packages, or
calculator-link software.

1. Select the stack of data cards containing the data you want to export.
2. Choose Export Collection from the Data menu.

3. Give the file a name, specify where you want it to be saved, then click OK. TinkerPlots
will create a tab-delimited text file with the names of the attributes in the first line. Plots,
text boxes, and other TinkerPlots objects will not be exported, just the data.

4. Switch to the application you want to view the data in, then use that program’s import
command to open the text file.

Working with Attributes

An attribute is a feature or characteristic of a case. If you collected data on how much weight
students carry in their backpacks, backpack weight would be one of the attributes you’d be
interested in. You might also collect from students their grade, gender, age, and body weight.
Each of these is also an attribute.

In data cards, attribute names are listed in the left column. In case tables, attributes are listed
along the top row. In plots, cases are arranged along the vertical or horizontal axis according to
their attribute values.

Add an Attribute

To add one or more attributes to an existing collection,

... In the Data Cards

1. Double-click the cell labeled <new attribute>. This is located on the bottom row of the data
cards. If you can’t see this cell, make the data cards larger by dragging the bottom edge.

Type the attribute’s name, then press Enter. (See Tips on Naming Attributes.)

3. To add additional attributes, repeat steps 1 and 2.

...lIina Case Table

1. Click in the cell labeled <news at the far right of the top row. (You may need to scroll the
case table window to the right to see this cell.)

TranzSiberiankail
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2. Type the attribute’s name, then press Enter. (See Tips on Naming Attributes.)

3. To add additional attributes, repeat steps 1 and 2.

Tips on Naming Attributes

Attribute names in TinkerPlots must begin with a letter or an underscore (_) and cannot include
spaces or special characters such as percent signs (%), dollar signs ($), and so on. Although you
can’t begin an attribute name with a digit, you can include digits anywhere else in the name
(Favoritel, Favorite2, and so on). For multiple-word attributes, capitalize the first letter of each
word (PackWeight) or use an underscore (Pack_Weight).
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Keep attribute names as short as you can while making it clear what they are. Rather than
including a unit as part of an attribute name (Weight_lb), enter the unit (Ib) in the Unit column of
the data cards.

Enter an Attribute Unit

Some attributes have units. Height might be measured in inches, for example, and Weighr might
be measured in pounds. You can enter the measurement unit in the Unit column of the data cards.
Unlike attribute names, unit names can have spaces and symbols (“US $,” for example).

To enter a unit,
1. In the data cards, click in the Unit column of the attribute.
2. Type the unit name.
3. DPress Enter.

By default, the unit will appear along with the attribute name on graph axes. To control this
display option, select a plot and choose Hide Attribute Units from the Options submenu of the Plot
menu.

Rename an Attribute

1. Double-click the attribute name in the data cards, case table, or plot.

2. In the dialog box, type the new name, then press Enter. (See Tips on Naming Attributes.)

Delete an Attribute

Deleting an attribute removes the attribute name and all its values from the collection. (If you
accidentally delete an attribute, immediately choose Undo from the Edit menu to restore it.)

To delete an attribute,
1. In the data cards or case table, click the name of the attribute you want to delete.
2. Choose Delete Attribute from the Edit menu.

e Delete Attribute doesn’t appear in the Edit menu? You probably have one or more cases selected
in the data cards. Click near the circle icon at the top of the data cards to deselect the
case(s).

Hide/Show an Attribute

You may want to create additional screen space in a case table by hiding some attributes. When
you hide an attribute, it’s still there, you just can’t see it. Note that you can hide attributes only
in a case table. Data cards always display all of the attributes, even those that are hidden in a case

table.
To hide an attribute in a case table,

1. Select the attribute you want to hide. (To select more than one attribute at a time, hold
down the Shift key.)

2. Choose Hide Attribute from the Data menu.
To see an attribute that is currently hidden,
1. Select the case table.

2. Choose Show Hidden Attributes from the Data menu.

Change Attribute Position

... in the Data Cards
1. Select the attribute whose position you want to change.
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4.

Choose Cut Attribute from the Edit menu.

Select the attribute name above which you’d like the cut attribute to appear. (If you
want the cut attribute to appear in the last position, don’t select an attribute.)

Choose Paste Attributes from the Edit menu.

If your attribute has a formula, the formula will not be moved with the attribute. To move an
attribute with a formula,

1.
2.
3.

¥ e N A

Select the attribute whose position you want to change.
Choose Copy Attribute from the Edit menu.

Select the attribute name above which you’d like the copied attribute to appear. (If you
want the copied attribute to appear in the last position, don’t select an attribute.)

Choose Paste Attributes from the Edit menu.
Select the original attribute you copied.
Choose Copy Formula from the Edit menu.
Select the copy of the attribute.

Choose Paste Formula from the Edit menu.

Select the original attribute you copied and choose Delete Attribute from the Edit menu.

. in a Case Table

1.
2.

Click the column head of the attribute whose position you want to change.

Drag the attribute name to the column location where you want it to appear.

Note: Changing the location of an attribute in the case table does not change the location of that
attribute in the data cards.

Change Attribute Color

TinkerPlots automatically chooses colors for attributes as you create them.

To choose your own attribute colors,

1.

Double-click the color bar beside the attribute name in the data cards (you can also
double-click the color bar in the color key of a plot). For numeric attributes, you can
click anywhere along the color bar. For category attributes (like Gender), there’s a
different color for each category (“Male” and “Female”), so click the color in the bar (or
color key) that you want to change.

In the color block (Win) or color wheel (Mac), click the new color you want and set the
brightness level.

Windows Color Block _
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Macintosh Color Wheel
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3. Click OK.

To revert to the default attribute colors,
1. Select the data cards.

2. Choose Reset Attribute Color from the Data menu.

Delete or Edit an Attribute Formula

When you delete the formula of a formula-defined attribute, TinkerPlots leaves the computed
values in place but treats them as noncomputed (as though you had typed them in). The values
in the data cards and case table turn from gray to black to indicate this change in status.

To delete or edit an attribute formula,

... Iin the Data Cards

1. Double-click the blue formula circle of the attribute. (If you can’t see the Formula
column, widen the data cards by dragging the right edge.)

(I
[ number ]
B ] even ]

2. In the formula editor, the entire formula will appear highlighted. To delete the formula,
press Delete. To edit the formula, click the part of the formula you want to edit and type
your revisions.

3. Click OK.

...In a Case Table
1. Double-click the formula cell below the attribute. (If you can’t see the formula row,
make sure the case table is selected, then choose Show Formulas from the Table menu.)

2. In the formula editor, the entire formula will appear highlighted. To delete the formula,
press Delete. To edit the formula, click on the part of the formula you want to edit and
type your revisions.

3. Click OK.
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Working with Values

Enter or Change Values
To enter or change a case’s value for an attribute,

... in the Data Cards
1. Click in the Value column of the attribute, type the value, then press Enter.

... Ina Case Table
1. Click in the appropriate cell, type the value, then press Enter.

You can also change a case’s value in a plot by using the Drag Value tool.

Round Values

To round numeric values, set the number format as described in Change Number Formats, or
create a new attribute using the round formula. (Using a round formula actually changes the data.
Using Change Number Format changes only how the data are displayed in data cards and case
tables.)

Change Number Formats

You can control the way numbers appear in data cards and case tables without changing the
number behind the appearance. For example, you can change the number of decimal places you
see or switch to scientific notation.

To control the appearance of numbers in case tables and data cards,

1. Select the attribute whose number format you wish to change by clicking its name in a
data card or case table.

Choose Format from the Data menu.

3. Choose the option that you want and click OK.
Format Attribute

® Dynamic & | Significant Digits

:- Fixed Decimal
R ) Example
_ Scientific Notation

—~ . . . 123.457
) Engineering Notation

Mote: Format affects display of numbers only, and has
no effect on numeric calculations, axis tick marks, or
the plotted position of data.

l\ Cancel :} ( 0K )

Changing the appearance of numbers in data cards or case tables will not affect where the values
are plotted on a graph axis. It also will not affect the results of the formulas. Sometimes you want
to round the actual numbers to the nearest integer value, and not just affect their appearance in
the data cards. To round the actual data values, make a new attribute using the round formula.

Number Formats

Dynamic

The dynamic number format works well for most purposes. It doesn’t display trailing zeros after
the decimal point, and it keeps things out of scientific notation.
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Fixed Decimal

This gives all numbers the same number of digits after the decimal point, as specified in the
Decimal Places field.

Scientific Notation

A number expressed in scientific notation has one digit to the left of the decimal point, as many
digits to the right as are specified in the Significant Digits field, and an exponent that tells you by
what power of 10 to multiply.

Engineering Notation

In engineering notation, the number of digits to the left of the decimal point is one, two, or
three, adjusted so that the power of 10 will always be a multiple of 3.

This chart gives some examples, all with six digits specified in the Format Attribute dialog box.

Entered Dynamic |FixedDecimal| Scientific | Engineering
" 1 1000000 1.00000e+00 | 1. 00000:+00
"12345" 12245 12245000000 | 1 23450e+04 | 12 Z4500+03
tazEt 00123 0.012300 1.23000e-02 | 12 Z000=-0F
"12345678" | 12345673 12245678.00... |1 .23457e+07 | 12 3457e+05
"12.3458T" 1234357 12 345870 1.2345Te+01 | 12 2457Te+00

Working with Cases

Add Cases
To quickly add any number of new cases to a collection,
1. Select a stack of data cards, a case table, or a plot.
2. Choose New Cases from the Data menu.
3. In the dialog box, enter the number of new cases to add and click OK.
4. Go to the newly created cases in the data cards or case table and enter data for the cases.

You can also add cases one at a time in data cards, case tables, or plots.

... in the Data Cards
1. Go to the last data card either by using the arrows at the top of the cards or by pressing
End on your keyboard. The last card in the stack is labeled “new case” in the upper-right
corner.

=

] Hame
] Gerder

2. Click in one of the cells in the Value column and begin entering the data for the new
case.

3. Press Enter. The new case will be added to the collection. Continue entering additional
values for that case.

...in a Case Table
1. Scroll to the last row of the case table (or press End).
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2. Click in one of the cells and enter the value for one of the attributes.

3. Press Enter. The new case will be added to the collection. Continue entering additional
values for that case.

...in a Plot
1. Choose the Add Case tool from the lower plot toolbar.
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2. Click in the plot to add a new case. If you have plotted attributes, the new case will be
assigned values depending on where you click. (To quickly add multiple new cases in the
plot, press Alt (Win) Option (Mac) either before or after choosing the Add Case tool.)

3. Add additional values for the new cases in the data cards or case table.

Delete Cases
1. Select the case(s) you'd like to delete in the data cards, plot, or case table.
2. Choose Delete Cases from the Edit menu.

Note: Deleting cases permanently removes them from the collection. If instead you want to
temporarily remove one or more cases from a plot, use the Hide Cases command, use a filter, or
restrict the range of a plot axis. You could also temporarily delete the case from the collection and
then later choose Undo from the Edit menu to restore it.

Sort Cases
To change the order in which cases appear in the case table,
1. Click on the name of the attribute you want to sort by.
2. From the Table menu, choose Sort Ascending or Sort Descending.

e How do I sort by more than one attribute? Suppose you want to sort by both grade level
and by name so that all the 11th graders (sorted by name) come before all the 12th graders
(sorted by name). First sort by name, then by grade. The sort by grade won’t disturb the
sort by name.

Get Case Information
Looking at a plot, you'll sometimes want to see all the information about a particular case. To do
this,
1. In the plot, click the case that you want information about. The data card for that case
will come to the top of the data cards stack. In the case table, that case’s row will be

highlighted.

Select/Highlight a Case

When you click a case, it is highlighted in all other objects in the document. If you have multiple
plots of the same data, this allows you to easily see where a particular case is in each plot. Also, to
delete a case, you must first highlight it. In data cards, you can only select one case at time. To
select multiple cases, use the case table.

TinkerPlots Help
© 2005 University of Massachusetts

26



To select a case,

. in the Data Cards

1.

Bring the case to the top of the stack by using the arrow keys in the upper-right corner
of the data cards.

Click the case circle in the upper-right corner of the card. A thick border will appear
around this circle to indicate that the case is now selected. To deselect the case, click
beside the case circle.

. in a Case Table

Select a single case by clicking its row number. The row will now appear highlighted.
Select more than one case by dragging along the cases’ row numbers.

Select contiguous cases by clicking the row number at one end of the desired location.
Then hold down the Shift key and click the row number of the case at the other end of the
series.

To select cases that are not contiguous, hold down Ctrl (Win) Command (Mac).

To deselect cases, click somewhere else in the case table.

.. in a Plot

To select a case in a plot, click the case icon. A thick border will appear around the icon.
Select more than one case by dragging a selection rectangle around the case icons.

Select non-contiguous cases in the plot by holding down the Shift key while using the
selection rectangle.

To deselect, click somewhere else in the plot.

Combine Collections

You can add one collection to another collection. These collections can be in the same document
or in different documents. Combining collections can be useful when students from different
classes have conducted the same survey and you want to put all the information into one
collection.

To combine collections,

1.

4.
5.
6.

Make sure that the collections have the same attribute names and that the attributes are
arranged in the same order in the data cards.

Select the stack of data cards that you want to add to the other stack.

Choose Select All Cases from the Edit menu. Then, from the same menu, choose Copy
Cases.

Click on the stack of data cards that you want to add the cases to.
Choose Paste Cases from the Edit menu.

Save.

Check to make sure that the number of cases in the new, merged collection is the sum of the
cases in the original two collections.
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Make a Data Subset

You can work with subsets of your data. For details, see Remove Some Cases from a Plot.

Rename a Collection

The name of a collection appears in the tab at the upper-left corners of plots, data cards, and case
tables. By default, the first collection created in a document is named Collection 1.

To rename the collection,
1. Double-click the collection’s name in the label.
2. Type the new name in the dialog box and click OK.
Or,
Select the stack of data cards, plot, or case table of the collection you want to rename.
Choose Rename Collection from the Data menu.

3. Type a new name in the dialog box, then click OK.

Prevent Collection Changes
Locking a collection will prevent you or someone else from mistakenly changing any of the data.
To lock a collection,

1. Select the collection you want to lock by clicking on the data cards, a plot, or a case

table.
2. Choose Lock Collection from the Data menu.
To unlock a collection,

1. Select the collection you want to unlock by clicking on the data cards, a plot, or a case

table.

2. Choose Unlock Collection from the Data menu.

Revert to Last Saved Collection

Sometimes you may have made several changes to your collection that you want to undo. These
changes may include additions of new cases or new attributes, cases or attributes you have
deleted, attribute colors you have changed, units you have added, or attribute formulas you have
edited. As long as you haven’t saved the changes, you can undo them in one step.

To remove all changes to your data since the last save,
1. Choose Revert Collection from the Data menu.
2. In the dialog box, click OK.

If you want to remove changes you made very recently, you may want to use the Undo command
instead.

Recoding and Creating Data

Most data that come from the real world need some work before you can use them to find
answers to your questions. Some of the more common situations and how to deal with them are
described in Common Uses of Formula-Defined Attributes.
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Working with Plots

TinkerPlots has no menu of graph types. It has no scatter plots, histograms, or pie charts. In
TinkerPlots, you construct graphs by progressively organizing the icons in the plot. You use
commands such as order, separate, and stack and different icon types and options to build up
what you want in stages. Nearly every operation works with all other operations, and by
combining these you can make many different kinds of graphs. Because of this, the best way to
learn TinkerPlots is to simply start experimenting with it.

Parts of a Plot

White button indicates “on” state.

/ Click to turn off.
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Make a New Plot

To make a new plot,

1. Draga plot from the object toolbar (upper-left corner of window) into the document
and drop it where you want it to appear.

In the plot you should see a random arrangement of circle icons. Each icon is a case in the
collection.

e Why is the plot empty?
If the plot is empty, it is probably because of one of two things.
e First, it could be that you have no data yet. Start entering data into the data cards.
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Second, the plot could be empty because you have more than one collection (stack of data
cards) open in the document. The program doesn’t know which data you want to plot.

To connect an empty plot to the correct set of data cards,

1.
2.

3.

Locate the stack of data cards that you want to plot.

Drag the name of the collection, located in the tab at the upper-left corner of the data
cards, into the empty plot. The whole plot window will highlight.

Release. The cases from the collection will appear in the plot as circle icons.

Basic Operations

You can apply the different operations and features of TinkerPlots in any order to make a
particular graph. Here we describe the three basic operations that you use to arrange case icons.
These are Stack, Order, and Separate. Using these in different combinations, you can make lots
of different graphs. The buttons for these three actions are located on the upper plot toolbar.
When a button is on, it appears white and you can see its outline. In the example here, Order
(vertical) is currently on. Clicking that button again would turn Order off.

1
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Stack

Stacking arranges case icons in horizontal or vertical rows. To stack case icons vertically or
horizontally,

1.

Click the Stack Vertical or Stack Horizontal button in the upper plot toolbar. Click that
button again to turn stacking off.
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Here’s some additional information about stacking.

You can’t stack both ways at the same time. So, if the icons are stacked horizontally and
you click Stack Vertical, the Stack Horizontal button will turn off at the same time the Stack
Vertical button turns on.

If it can, TinkerPlots will stack the icons in a single column (or row). However, there often
isn’t enough room in the plot to do this. So TinkerPlots “wraps” the stack around, making
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multiple columns or rows. If it needs even more room, TinkerPlots will squish the icons
together. If you want to reduce the wrapping or squishing, make the plot window larger
and/or the case icons smaller.

e In some situations, stacking will do nothing to the plot (for example, when you have a
scatter plot or a plot using Fuse Circular icons).

e By default, icons are stacked in random order. You can stack them in case order by
choosing Stack by Case Order from the Options submenu in the Plot menu.

Tip: Make a stack and then order it by a numeric attribute. This makes a very simple graph that
shows how cases “stack up” on a particular attribute. Below is a graph of dinosaurs, stacked and

ordered by their height. If your question is “Who are the tallest and shortest?” this graph may be
just what you need.

Carmar a5 aurus
Driplodocus
Fachycephaksaurus
Tyrannos aurus

Far as auro loph us

Edmio ntos aurus
bertos aurus
Triceratops

s alimimus

5 - Tenontos aurus

count, ordered by Height [m]

Euop locep halus
Creinonychus
Traodan
Psittacozaurus
O rod romeus
flaz= o= po ndy (s
Chviraptor

Hyps lophodon
Crromaens aurus

Carmps agn athus

Order
Ordering arranges cases by their attribute values. To order case icons vertically or horizontally,
1. In the data cards, click the attribute you want to order by. This will select that attribute
and use its color scheme to color the case icons in the plot.

2. In the upper plot toolbar, click the Order Vertical or Order Horizontal button. Click that
button again to turn order off.

When you have order turned on, the name of the attribute you’ve ordered by appears in the plot
window. For horizontal order, the name appears along the bottom of the window. For vertical
order it appears along the left side. If there is also an attribute on an axis, the name of the ordered
attribute appears after it, following a comma.
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Here’s some additional information about ordering.

e You can have both order buttons turned on at the same time, ordering in one direction by
Height, for example, and in the other direction by Weight.

e For numeric attributes, cases are arranged in ascending order, from smallest (bottom or
left) to largest (top or right). You can arrange in descending order by holding down Alt
(Win) Option (Mac) as you order.

e For category attributes, cases are ordered alphabetically by the attribute’s values. For
example, you might use the words “One,” “Two,” “Three,” and “Four” to code the Grade

students are in. If you ordered the cases by Grade, TinkerPlots would order them “Four,”
« » <« » « »
One,” “Three,” “Two.

e In some situations, ordering will do nothing to the plot (for example, it will not affect a
scatter plot). The reason is that the case icons are “locked in place” in a scatter plot and
there is no direction for them to move to show their order for another attribute.

Separate

This operation separates the cases in a plot according to their attribute values. For example, with
a collection on students at your school, you might want to separate “male” from “female,” or
place students into separate groups according to their ages.

When you separate cases into groups, TinkerPlots adds bin lines between the groups, puts the
name of the attribute you are separating by on the axis, and displays labels along the axis (such as
“male” and “female”) to show what’s in each group.

3

female male
SEX
There are three ways to separate icons into groups:

. by Dragging a Case Icon

1. In the data cards, click the attribute you want to separate by. This will select that
attribute and apply its color to the case icons.

2. In the plot, drag a case icon either to the right or up to make two (or more) groups.
(Drag to the left or down to make fewer groups.) Bin lines will appear between the
groups.

Separate works a little differently with numeric and category attributes. With a category attribute,
when you first drag you’ll make only two groups. If you want to make more groups, go to the
group labeled “other” and pull out another case/group. To make fewer groups, drag a case from a
separated group towards the group label “other.” With a numeric attribute, you can make from
two to eight groups while dragging before the attribute fully separates. To make more groups,
drag any case icon to the right or up. To make fewer groups, drag to the left or down.

If there is already an attribute on the axis along which you’re dragging, that attribute will not be
replaced by a different, selected attribute. In this case, dragging will only change the number of
groups of the attribute already on the axis.

. .. by Dragging an Attribute Name to an Axis
1. In the data cards, click an attribute name and drag it into either the left side or the
bottom of the plot. The axis will highlight when you’re over the right area.
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If there is already an attribute on the axis, the new attribute will replace it. If there is no attribute
on the axis, the attribute name you dragged will appear there. If the attribute is numeric, the
cases will separate into two groups. If you want more groups, drag an icon to the right or up.

When you drag a category attribute to an empty axis, it will fully separate into as many groups as
there are value types.

... by Clicking the Separate Button

1. In the data cards, click the attribute you want to separate by. This will select that
attribute and apply its color to the case icons.

2. In the upper plot toolbar, click either the Separate Vertical or Separate Horizontal button.

The selected attribute name will appear along the axis and the cases will separate into two groups.

Mix Up
To return a plot to its original, disorganized state,

1. Click the Mix-up button on the lower plot toolbar.

The Mix-up button removes all features that have been added to a plot, including any attributes on
the axes. The case icons will scatter randomly. If the icons are already mixed up, they will move
to new random locations.

Remove an Attribute from an Axis
To remove an attribute from an axis,

1. In the upper plot toolbar, click the Separate Vertical button to remove an attribute from
the vertical axis; click the Separate Horizontal button to remove an attribute from the
horizontal axis.

Or,

1. For a numeric attribute, drag any case all the way to the left (or down). For a category
attribute, drag a case from one group towards another group. This will create a
combined group called “other.” Continue dragging groups towards the “other” group
until there are no bins remaining.

Replace an Attribute on an Axis
To replace an attribute on an axis with another attribute,

1. From the data card or case table, drag an attribute name and drop it on top of the
attribute name currently in the plot.
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Plot Two Attributes

To make a graph of two attributes,

1. In the data cards, click an attribute name and drag it into the bottom of the plot. The
axis will highlight when you’re over the right area.
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2. Click another attribute name in the data cards and drag it to the left side of the plot.

Swap Axes
To swap axes so that the attributes on the horizontal and vertical axes change positions,
1. Choose Swap Axes from the Plot menu.

This also works when only one axis has an attribute. That attribute will move to the other axis.

Display Attribute Units

Some attributes have units visible in the Unit column of the data cards. By default, when an
attribute name with units appears on an axis, the units are also displayed. If you don’t want units
to appear on the axes,

1. Choose Show Attribute Units from the Plot menu.

Choosing the option will remove the check mark and turn the option off. To turn it back on,
choose it again.

Bins and Axes

Change Number of Numeric Bins

There are three ways to change the number of bins in graphs that have numeric axes:

... by Dragging a Case Icon in the Plot
1. In the plot, drag a case icon to the right (or up) to make more bins; drag left (or down)
to make fewer bins.

By dragging icons, you can make from two to eight numeric bins. If you keep pulling after you

have eight bins, the case icons will fully separate.
... by Dragging a Bin Line

1. In the plot, place the cursor over one of the bin lines. The cursor will change into a
double arrow.

2. To make more bins, drag the bin line left (or down); to make fewer bins, drag the bin
line right (or up).

By dragging bin lines, you’ll be able to make as many bins as you want before the attribute fully
separates. As you drag the bin line, the axis labels change dynamically.

... by Changing the Axis Interval
1. Double-click one of the axis endpoints. (The endpoints are outlined in gray.)

2. In the dialog box, enter a new bin width and click OK. (Entering a smaller value will
increase the number of bins. Entering “0” will fully separate the numeric axis.)

Change Number of Category Bins

You can separate all values of a category attribute either in one step or one category value at a
time.

. .. Separate One Bin at a Time
To increase the number of category bins one bin at a time,

1. In the plot, go to the bin labeled “other” and drag any case icon out of the bin. That
case, and all the cases with the same value, will move into a new bin.
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2. Repeat step 1 until you have made as many bins (groups) as you want, or until the
attribute is fully separated.
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To decrease the number of category bins one bin at a time,

1. In the plot, go to a bin with only one type of value. For example, if the attribute is
Eye_Color, you might go to a bin labeled “blue.”
2. Drag a case from that bin toward the bin labeled “other.” All the cases in the “blue” bin

will move into the “other” bin. (If the attribute is already fully separated, dragging
toward any bin will combine two bins and make a new “other” bin.)

... Separate Fully into Bins in One Step
To fully separate a category attribute into as many bins as possible in one step,

1. From the data cards, drag the name of the category attribute onto one of the plot axes
(located on the left side and bottom of the plot).

All of the different values of the attribute will be visible on the axis.

You might now want to create an “other” bin by combining two particular categories. First move
the two bins that you want to combine next to each other (see Reorder Category Bins). Then
drag a case icon from one of the bins into the other bin. These two groups will mix in a new bin

called “other.”
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Adjust Axes

Change Axis Enapoints and Bin Widths

TinkerPlots automatically sets numeric axis endpoints and bin (or interval) widths. But
sometimes you’ll want to set these yourself. For example, you might want to make the axes for
two plots identical. Or you might want to zoom in on part of the graph where cases are bunched
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together to see what’s going on there. Or you might be dragging an extreme value to watch what
happens to the mean and want to prevent the axis from automatically changing, which it would
ordinarily do.

To adjust bin widths or axis endpoints of a numeric axis,

1. Double-click the axis endpoint you want to change or the width of the first or last bin.
These endpoints and widths are lightly outlined in gray.

In the dialog box, enter the value you want for the endpoint or bin width.
3. Click OK.
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In the example above, the endpoint was changed from 40 to 30. The case near 40 has moved off
the axis and into the “excluded cases” stack, marked with an asterisk (*). Also, the upper end of
the axis now has a >> symbol added. This tells you that there is at least one value beyond the
current axis maximum of 30 that is not plotted over the axis.

At the same time you set a maximum or minimum for your axis, you can also set a bin width.
Note that if you set both a new bin width and a new maximum, TinkerPlots might have to
change the minimum value on the axis to give you what you want.

Return to Default Axes
If you have edited your axes but now want to return to the default settings,

1. Drag the attribute name from the data cards back onto the axis.

Reverse Axis Endpoints

By default, a numeric axis increases in value from left to right or from bottom to top. To reverse
an axis so that the values decrease from left to right or from bottom to top,

1. Drag one of the axis endpoints (outlined in gray) toward the other end of the axis.

Reorder Category Bins

You can freely reorder the bins of a category attribute. For example, you might want to arrange
them according to how many cases are in each bin.

To move a category bin to a different place on the axis,

1. Drag a bin label to a new location along the axis.
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Use Continuous-style Bins

By default, bins of numeric attributes are labeled with their individual ranges, as shown on the
vertical axis of the plot below. As an option, you can use a continuous style of labeling bins, as
shown on the horizontal axis.

To use continuous-style bins,

1. Select the plot, and choose Continuous-style Horizontal Bins or Continuous-style Vertical Bins from
the Options submenu in the Plot menu.

2. Choose the option again to revert to standard bins.
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Case Icons

Icon Size

Case icons can be as small as 1 pixel and as large as 32 pixels across. There are three ways to
change the size of case icons:

... Using the Icon Size Slider
1. In the lower plot toolbar, drag the lcon Size slider to the right to make icons larger or
toward the left to make them smaller.

... Using the Icon/Tool Options Menu
1. In the lower plot toolbar, click the small triangle to the right of the Drawing tool. This
opens the Icon/Tool Options menu.
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Icon Size 4
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From the menu, choose one of four icon-size options or choose Icon Larger or Icon Smaller to adjust
icon size in one-pixel steps.

... Using Shift/+ and Shift/-
1. Press the Shift key along with the + or - key to change the case icon size one pixel at a
time.

Labels for Case Icons
You can add a label to each case icon. You can use this feature to show, for example, the name of
each student in a collection or the gender of each case.
To label the icons in a plot with their attribute values,
1. In the data cards, select the name of the attribute you want to label by.

2. In the upper plot toolbar, click the Label button.

To change the attribute you use for labeling, turn off the Label button (by clicking it) and then
repeat the steps above.

To change the position of the case icon label,

1. In the upper plot toolbar, click the small triangle to the right of the Label button. This
opens the Label Options menu.

aobc.tls ’
L3 Labels Centered L
Labels Inside
Labels on Left
Labels on Right
Labels Above

v Labels Below

2. Choose the location you want.

Labels do not resize as you change the size of case icons. Because of this, labels usually are not
very useful with large collections. However, you can make the case icons very small so that all you
see is the labels. This is a way of making the labels themselves a type of case icon.

Case Icon Types
You can choose one of several icon types from the lcon Type menu on the lower plot toolbar. The
name of the icon type currently being used in a plot is visible in the lower plot toolbar. The
default setting is Circle Icon.
To change to one of the other icon types,

1. Click the small black triangle to the right of the icon type in the lower plot toolbar.

2. From the menu, choose the icon type you want.

v @ Circle Icon
o Square lcon
4% Image Icon
£ Value Bar Horizontal
il Value Bar Vertical
[ Fuse Rectangular
45 Fuse Circular

Borderless Icons
Hide Icons

Here’s a brief description of the different icon types.

Circle Icon: By default, each case appears as a circle.
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Square Icon: Each case appears as a square. You can stack squares to make graphs that look more
like conventional bar graphs.

Image Icon: Each case appears as an image (for example, a cat or a person). You can change image

icons or even make your own.
Value Bar Horizontal: Each case of a numeric attribute appears as a horizontal bar. The length of
the bar shows the case’s value.

Value Bar Vertical: Each case of a numeric attribute appears as a vertical bar. The height of the
bar shows the case’s value.

Fuse Rectangular: Case icons are joined together into rectangles (as in histograms). Individual
cases are still potentially visible as individual squares or rectangles.

Fuse Circular: Case icons are joined together into circles (as in pie graphs). Individual cases are
still potentially visible as individual pie wedges.

Borderless Case Icons

Case icons typically have a black border around them to make cases distinct from one another.
Sometimes, especially with large collections, these black borders make a graph harder to read.

To remove the black borders from case icons,
1. Choose Borderless Icons from the Icon Type menu on the lower plot toolbar.

That option will now appear in the Icon Type menu along with a check mark. To put borders back
on icons,

1. Choose Borderless Icons again to uncheck it.

Invisible Case Icons

By resizing case icons you can make them as small as one pixel in diameter. But sometimes you’ll
want them to disappear completely, such as when you make a box plot or frequency table. To
make the case icons invisible,

1. Choose Hide Icons from the Icon Type menu on the lower plot toolbar.
That option will now appear in the Icon Type menu along with a check mark. To make the case
icons visible again,

1. Choose Hide Icons again to uncheck it.

Reposition Case Icons

You can manually reposition icons in a plot. You might want to do this to spread out icons that
are too close to, or overlapping, one another. You also might want to put case icons into
groupings yourself, rather than have TinkerPlots do it for you.

You can freely reposition icons in a mixed-up plot. But you can also reposition icons in a plot
that has bins (a plot where there is an attribute on at least one of the axes). You can also choose
to have dragging always reposition cases, rather than separate them.

... in a Mixed-up Plot
To move case icons freely within a plot,
1. In the data cards, click the light blue bar to the left of the Attribute column heading. This
deselects all attributes and makes the case icons the same blue color.

2. Click on a case icon and drag it to where you want it. Or select several cases at once and
drag them together to a new location.

You can also apply an attribute’s color scheme to the mixed-up case icons and still reposition
them. To do this, hold down the Alt (Win) Option (Mac) key before you drag. By holding down
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this key, you prevent the icons from separating into bins when you drag them. (Note that with
this key down, the cursor looks like a hand when it’s over a case.)

... In a Binned Plot
To reposition case icons within a bin,
1. Hold down the Alt (Win) Option (Mac) key.
2. Drag the case you want to move to a new position within the bin. (If you move a case

outside the bin, it will come back into the bin when you release.)

If the cases are stacked within the bin, you will not be able to move a case icon anywhere you
want and have it stay there. The icons will stay stacked as long as Stack remains on.

If the cases in a bin are not stacked, you can remix all of them within the bin. To do this,

1. Choose Remix from the Plot menu.

... in Any Plot
To make sure that dragging always repositions icons (rather than separates them),

1. Choose Drag Case Always Repositions from the Options submenu of the Plot menu.

Change Image Icons

Each collection that comes with TinkerPlots has an image icon available. The collection Cats.tp
has images of cats; the collection Backpacks.tp has images of people. The document Case Icon
Library.tp contains a collection of image icons you can use. The default image icon is the ball from
the TinkerPlots logo.

To change the image icon of a collection,

1. Open the document Case Icon Library.tp. This file should be in the TinkerPlots | Data and
Demos folder on your computer.

Click the icon you want to use to select it.
3. Choose Copy as Picture from the Edit menu.

4. Return to your TinkerPlots document and select the plot you want to paste this icon
into.

5. In the lower plot toolbar, open the Icon Type menu and choose Paste Image Icon. The new
image icon will appear in the plot.

6. Save. The image icon is saved with the collection. All plots using that data can use this
image icon.
There are some disadvantages of using image icons in graphs rather than, say, circles. Image icons
can make a graph look busy and make it harder to see general trends in the data. They also often
make it harder to see the colors of the icons. And they take more computer memory and can slow
down TinkerPlots animations. If TinkerPlots seems slow with image icons on, use circle icons to

speed things up.

Make Your Own Image Icons

You can draw or modify an image to use as an image icon, using any painting or image editing
program such as Microsoft Paint or Adobe Photoshop.

No matter what size you make an image icon, it will be resized to 32 by 32 pixels when pasted
into a TinkerPlots document. So, to avoid distorted case icons it is best to use or make images
that are 32 pixels square.

There are three parts to an image icon: the “visible parts” that make up the image, the “fill parts”

that get colored with the attribute’s color scheme, and the “transparent parts” such as the area
around the image that will not be visible in TinkerPlots.
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Here are some specifications to help you make each of these parts of an image icon.
Visible pars: Black is best, because colors may compete with the attribute’s colors.

Transparent parts: Use pure white (100% value plus 0% saturation, or RGB “255,” or Web color
“FFFFFF,” depending on the color picker you use).

Fill parts: Use 80% gray (80% value plus 0% saturation, or RGB “204,” or Web color
“CCCCC,” depending on the color picker you use).

Copy Image Icons

You can copy pictures to use as image icons from any program that supports display and copying
of images. This includes Internet Explorer, Microsoft Paint, Word, QuickTime, and Adobe
Photoshop.

To copy an image from another application and paste it directly into TinkerPlots,
1. Select the image in the application, then choose Copy from the Edit menu.

2. Switch to TinkerPlots and choose Paste Image Icon from Icon Type menu in the lower plot
toolbar.

To also paste the image into the Case Icon Library where it will be available for other collections,

1. Open the document Case Icon Library.tp and click in the document background (white
area). No frames around images icons should be visible.

2. Choose Paste Picture from the Edit menu.

Reference Lines

You can add one or more reference lines to any kind of plot. You can use these to help you sight
to an axis, mark a critical cutoff point, or call attention to a particular part of the graph or case.
Here we describe how to add, move, split, and get rid of reference lines. For some purposes, you
may find that dividers are more useful.

Add/Remove a Reference Line
To add a single reference line to a plot,
1. In the upper plot toolbar, click one of the Ref. line buttons.
T —
Ref.
Using the buttons, you can add one vertical reference line and one horizontal reference line.
To add more than one reference line in the same direction,

1. Click the small triangle to the right of the Ref. line buttons. This opens the Reference Line
Options menu.

2. Choose Add Vertical Line or Add Horizontal Line.
To remove a reference line,
1. Click the Ref. line button to turn it off.

If you have several vertical reference lines, clicking the Ref. Vertical button will remove all of them.
There isn’t a way to remove them one at a time.

Reposition a Reference Line
1. Move a reference line by dragging its little square knob.
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Read Axis Values with a Reference Line

If you have a continuous numeric axis, a reference line will display its position along that axis
above (or to the right of) the square knob. With categorical axes or binned numeric axes, no
values are displayed above (or to the right of) a reference line.
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Split and Unsplit Reference Lines

When you have a reference line that goes across two or more bin lines, you can split the reference
line so that you can move reference lines independently in each bin.
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To split a reference line,
1. Click the small triangle to the right of the Ref. line buttons to open the Reference Line
Options menu.
2. Choose Split Reference Lines.
A check mark will now appear in the menu next to the Split Reference Lines option. To re-join the
reference lines, choose Split Reference Lines again. The check mark (and split in the line) will go
away.

Dividers

You can use dividers on graphs with fully separated numeric attributes to divide the graph into
sections. You can also use dividers along with counts or percents to see the number or proportion
of cases in each section. The example shows the year in which each of the 50 U.S. states was
admitted to the Union. Dividers are placed to show that by 1840 half of the 50 states had been
admitted and that by 1880 another 26% had been added.
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Add/Remove Dividers
To add two dividers to a graph with a fully separated numeric attribute,
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1. Click the Div. button in the upper plot toolbar.
m -
D

2. Click the Div. button again to remove the dividers.

Reposition a Divider
To reposition a divider,
1. Drag the divider by the white, square knob at the top of the divider.

Add Several Dividers

By default, you get two dividers when you click the Div. button. (Note that two dividers make
three groups or divisions.) To add any number of dividers,

1. Click the small triangle to the right of the Div. button to open the Dividers Options menu.
2. Choose Number of Divisions or Equal Width Dividers.

3. In the dialog box, enter the number of divisions you’d like and click OK. Note that if you
ask for five divisions, you'll get four dividers.

Equal Width and Equal Count Dividers

Equal width dividers divide a fully separated numeric axis into sections that have the same
interval width along the axis. Equal count dividers create divisions that each contain roughly the
same number of cases. To make either of these types of dividers,

1. Click the small triangle to the right of the Div. button. This opens the Dividers Options
menu.

Choose Equal Width Dividers or Equal Count Dividers.

3. In the dialog box, enter the number of divisions you’d like and click OK. Note that if you
ask for five divisions, you'll get four dividers.

Split and Unsplit Dividers

When you have dividers that go across two or more bin lines, the dividers are “split” by default so
that you can adjust each set of dividers independently. To join (or “unsplit”) these dividers so
that one set of dividers runs across all the bin lines,
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1. Click on the small triangle to the right of the Div. button. This opens the Dividers Options
menu.

2. The option Split Dividers will have a check mark next to it. This indicates that the dividers
are currently split. Choose this option, which will join the dividers. (If you look in the
menu again, the option will now be unchecked.)

Hat Plots

Hat plots divide a numeric attribute into three sections that look somewhat like a hat. There is a
central “crown” and, on either side of the crown, two “brims.” The brims extend out to the
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minimum and maximum values. The example shows a percentile hat plot for the body lengths
(in inches) of 100 cats and includes a stacked dot plot distribution of the same data.

25-T3 Percertile Hat Plot of Body (inches)
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To make a hat plot,

1. Add a numeric attribute to an axis and fully separate it.
2. In the upper plot toolbar, click the Hat button.

In the Hat Options menu, you can select among four types of hat plots. Each type uses a different
rule for constructing the central crown.

Hat plot type Crown edges
Percentile (default) 25th and 75th percentiles
Range 1/3 and 2/3 of the range
Average Deviation* —1 and +1 average deviations
Standard Deviation* —1 and +1 standard deviations

* The average deviation and standard deviation are measures that tell you how far, on average,
each score is from the mean. You can find the formula for the standard deviation in most
statistics books. You hear less often of the average deviation, but it is easier to understand.
Suppose you had the heights of 20 males and that the mean of the 20 heights was 65 inches. To
compute the average deviation, you’d start by subtracting the mean of 65 from each of the 20
scores. So if the first male in the collection was 63 inches tall, you'd get a difference of -2 after
subtracting the mean. You’d ignore the sign and just call the difference 2. The next height might
be 65.5 inches, and you’d get a value of 0.5 inch after subtracting the mean. After computing
this difference for each score, you’d add all the differences. Finally, you’d divide this sum of
differences (say it was 30) by the number of cases, 20. This would give you an average deviation
(in this example) of 1.5 inches, which would tell you that on average each score is 1.5 inches
from the mean.

The default locations of the crown edges of each type of hat plot are somewhat arbitrary, but you
can adjust them by dragging either crown edge once the plot appears. In this way, you could
make percentile hat plots that included 90% of the cases in the center part, or standard deviation
hat plots that included all the values between —2 and +2 standard deviations.

Counts and Percents

Counts show the number (or percent) of cases within each section of a graph. To see the number
or percent of cases that are in various parts of a graph,

1. In the upper plot toolbar, click the Counts (n) button or the Counts (%) button.
n %

Counts

If there are no sections (bins or dividers), the Counts (n) button will show the total number of cases
in the plot.
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Percent Display Options

For binned graphs with attributes on both axes, there are three types of percents you can display
in a cell (a cell is created by the intersection of two bin lines, as in the example).

Row Percents

By default, TinkerPlots displays row percents. Row percents are computed by dividing the
number of cases in a cell by the total number of cases in that same row. In the example below,
the 60% in the upper left cell is a row percent. It tells you that of the total 55 students with

curfews, 60% (33 + 55 x 100) report spending from 0 to 8 hours on homework per week. The
percents along the top are all blue to remind you that these are row percents (note that the
percents in each row sum to 100%, with possible rounding error).
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Column Percents

Column percents are computed by dividing the number of cases in a cell by the total number of
cases in the same column.

To display column percents,

1. In the upper plot toolbar, click on the small triangular button to the right of the Counts
(%) button. This opens the Percentage Options menu.

IET

2. Choose Show Column Percents.

If in the example you switch to column percents, the value in the upper-left cell changes from
60% to 73%. This column percent tells you that of the 45 students who reported spending from

0 to 8 hours per week on homework, 73% of them (33 =+ 45 x 100) had a curfew. The percents
in the same column are all the same color (blue or black) to remind you that these are column
percents.
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Cell Percents
Cell percents are computed by dividing the number of cases in a cell by the total number of cases
displayed in the plot.
To display cell percents,
1. Click on the small triangular button to the right of the Counts (%) button in the upper
plot toolbar. This opens the Percentage Options menu.
2. Choose Show Cell Percents.
If you switch the example graph to cell percents, the value in the upper left cell would change

from 60% to 40%. This cell percent would tell you that of the total 82 students, 40% (33 + 8 x
100) both have a curfew and report spending from 0 to 8 hours per week on homework. The
percents in all the cells would be black to remind you that these are cell percents.
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Averages

You can add symbols to a graph to show the location of the mean, median, mode, or midrange of
a numeric attribute. (The midrange is the “middle of the range” computed by subtracting the
minimum value from the maximum value and dividing by 2.)

On axes of fully separated numeric attributes, the symbols for these various averages will appear
just below the axis. The symbol points to the location of that average on the axis. With a binned
axis (not fully separated), a colored line will appear below the bin that contains the average. A
blue line is used for the mean, red for median, gold for mode, and green for midrange. (NVoze:
Lines are used with binned axes because the position of cases within a bin is arbitrary. A case
farther to the right than another case in the same bin does not necessarily have a greater attribute
value. Thus it would be misleading to try to show exact locations of averages within bins.)

Mean and Median
To add a symbol or line showing the location of the mean (.ﬂ) or the median (J-) of a numeric
attribute,

1. In the upper plot toolbar, click the blue triangle (mean) or the red inverted T (median).

Mode and Midrange

To add a symbol or line showing the location of the mode () or the midrange (H) of a numeric
attribute,
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1. Click the small triangular button to the right of the Averages buttons in the upper plot
toolbar. This opens the Average Options menu.

2. Choose Show Mode or Show Midrange.

Note that there may be multiple modes (most frequently occurring values) for an attribute. For
binned axes, TinkerPlots considers a mode to be the iz that has the most values. Thus the values
of modes can change as you change bin widths. Also, TinkerPlots doesn’t show the location of
modes for category attributes even though category attributes do have modes.

Display Values of Averages
To display values of averages,

1. Click the small triangular button to the right of the Counts (%) button in the upper plot
toolbar. This opens the Average Options menu.

2. Choose Show Numeric Value(s).

You can find the values of averages without displaying those values in the plot. If you place the
cursor over the average symbol in the plot, the value of the average will be displayed in the lower-
left corner of the document window. For fully separated axes or histograms, you can also use a
reference line to get a close estimate of the value of an average. Place the reference line directly
over the average symbol and then read off the axis position at the top of the reference line.

Color Key

When you select an attribute, the icons in the plot are colored with that attribute’s color scheme.
You can add a color key to a plot. It shows you what attribute is currently selected and what
values are associated with the colors. Below are two examples of color keys, one of a category
attribute (Grade) and the other of a numeric attribute (BPWeight). For a category attribute, the
key shows the color for each value (each grade in this example.) For a numeric attribute, the color
key shows the color of the gradient and the range of values of the attribute in the plot (3 to 39 in
this example).
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To add a color key to a plot,
1. In the upper plot toolbar, click the Key button.

Resize the key by dragging on a border. Move the key by clicking in a blank area within the key
and dragging.

Lock Plot Color

You can lock a plot’s color key to prevent the plot color from changing. This is useful when you
have two or more plots of the same data. With multiple plots in a document, each time you
select a new attribute, the plot color changes in all the plots. This is sometimes useful, but
sometimes not.

To lock a plot’s color,
1. In the upper plot toolbar, click the Key button.
2. Click the lock icon in the color key. The lock will close.

3. To unlock, click the lock again. It will open.
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Note that if you lock a color key, you cannot remove the key from the plot until you unlock it.
This is to help you remember that the plot color is locked.

Change Attribute Color Scheme

You can change an attribute’s color scheme from the data cards or from the color key.

Get Case Information

Looking at a plot, you sometimes want to see all the information about a particular case. To do
this,

1. In the plot, select the case that you want information about.

The data card for that case will come to the top of the stack of the data cards. If you have a case
table open, that case’s row will be highlighted.

Highlight Cases

You can select one or more cases in a plot to highlight them. Highlighted cases appear in the plot
with a thicker, black border around them. When there is no attribute selected, cases are
highlighted in red. This makes them stand out even more.

e Select a single case by clicking its case icon.

e Select multiple cases that are clustered together in the plot by clicking in an empty part of
the plot and dragging a rectangle around the icons you want to select.

e Select multiple cases that are not clustered together by holding down Shift and clicking each
case.

e To make selected cases stand out, remove the plot color by clicking in the data cards on the
light blue bar to the left of the Attribute column heading.

e To deselect cases, click somewhere else in the plot.

Brushing

When you highlight cases in a plot, those cases are highlighted in all other plots in the document.
Highlighting cases in multiple plots is sometimes called brushing. It is a powerful way to detect
interesting patterns or trends in the data. For example, in the data set US Students.tp you could
make two graphs, one of students’ heights and the other of their weights. Then you could
highlight all of the tall students in the height graph and see where those students are on the
weight graph.

Connecting Lines

When the data have been entered in a particular order, it is sometimes helpful to connect the
cases in the plot with lines. The lines connect the cases according to their case order (from case 1
to case 2 and so on). This is especially useful with graphs of time series.

To connect the cases with lines according to their case order,
1. Choose Show Connecting Lines from the Plot menu.

Caution: For most graphs, connecting cases with a line will make a mess. This option is useful
only when the data have been entered in an order that is meaningful. For example, the collection
in NY Marathon.tp is the winning times for the New York City Marathon, an event held every year.
The cases in the collection have been entered in the order they were collected over the years.
Therefore, when you connect the cases with a connecting line, the line goes from the first case, to
the second case, and so on to the last case. So, when you make a graph with the year of the
marathon on one axis, connecting the cases with a line makes a meaningful graph.
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Remove Some Cases from a Plot

At times you want to see only a subset of the cases in a collection. For example, if you are
exploring people’s yearly incomes, you probably don’t want to include children and retired
people in your graph. You can remove cases from a plot in two ways: by selecting and hiding the
cases, and by making a filter using a formula.

When you remove cases in these two ways, those cases not only disappear from the plot, they are
also ignored in computing percents, computing averages, and drawing box plots. Removing cases
is therefore different from changing a plot’s axis so that you can’t see some of the cases.

Hide Cases
To hide one or more cases,

1. Select the case icons you want to hide. To select a single case, click on it. To select
multiple cases, you can either click in an empty part of the plot and drag a rectangle
around them or hold down the Shift key while you click each icon.

2. Choose Hide Selected Cases from the Plot menu.

You can repeat these steps as many times as you like, removing more and more cases from the
plot. Also, you can choose Hide Unselected Cases from the Plot menu to hide the unselected cases.

To restore hidden cases to your plot,

1. Choose Show Hidden Cases from the Plot menu.

Filters

With a filter, you remove cases from a plot by using a formula that tells TinkerPlots which cases
you want to keep in the plot.

To add a filter to a plot,
1. Choose Add Filter from the Plot menu.
2. In the formula editor, enter the expression you wish to use as a filter, then click OK.

In the formula editor, you’ll generally want to type in an attribute name, a symbol such as = or <,
and then an attribute value. For example, typing Height > 70 would keep in the plot only
cases with values of Height more than 70. Typing Gender = “males” would keep only the
males. (Note that you need to put category-attribute values in quotes.) (See Enter a Formula for

more help.)
When a plot is being filtered, the formula of the filter appears below the plot.
To edit a filter,
1. Double-click the formula located at the bottom of the plot.
2. In the formula editor, edit the formula, then click OK.
To remove a filter,
1. Choose Remove Filter from the Plot menu.

When a filter is removed, its formula is not erased. The next time you add the filter to the plot,
the same formula will appear. You can toggle back and forth between the filtered and unfiltered
state by pressing Ctrl+F (\Win) Command+F (Mac).

Change Data Values

You can change the values of cases directly in a plot by dragging a case icon along an axis. As you
drag, the case changes its value to the position you've dragged it to. This works for both numeric
and category attributes.
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To change the value of a case in a plot, you need at least one attribute on an axis.

1. In the lower plot toolbar, choose the Drag Value tool.

=

2. In the plot, move the cursor over the case icon you want to move. The cursor will
change into a left-pointing arrow.

3. Drag the icon to a new location to change its value. (In the data cards, you can see the
value changing.)

When you release the mouse, the Drag Value tool turns off. If you want to change the values of
more than one case, repeat the steps above. Or hold down the Alt (Win) Option (Mac) key as you
click on and drag cases. As long as you hold down this key, the Drag Value tool will stay on.

If you drag a case along a binned, numeric axis, the case is given the value of the lowest value of
the bin. So a case dragged into a bin of heights that ranged from 60 to 63 would be given the
value 60.

If the plot has attributes on both axes, you can drag a case both horizontally and vertically,
changing its values for both attributes at the same time. If you want the case to change its value
for only one of the graphed attributes, be careful to move it in only one dimension.

Tip: You can use the Drag Value tool to demonstrate the influence of an extremely high or low
value on the mean. The graph shows how many dollars per hour high school students earned in
their part-time jobs. The location of the mean (about $5/hour) is shown as a blue triangle under
the axis. Using the Drag Value tool, move the case at $10/hour toward the center of the graph. As
the case moves to the left, the mean triangle will also move to the left, but more slowly, of course.
The reference line placed over the current mean helps show how much the mean changes. Also,
the demonstration works better if you fix the maximum value of the axis at 10, to prevent the
axis from automatically changing as the maximum value changes.
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Add New Cases

You can add new cases directly in a plot. If you have a plot with attributes on the axes, the new
case will be given values for the attributes based on where you place the new case.

To add a new case to a plot,
1. In the lower plot toolbar, choose the Add Case tool.

-

Move the cursor into the plot. It will change into a crosshair.

Position the cursor where you want the new case to appear and click. A new case icon
will appear. A new data card will also be created for that case and will move to the top of
the stack.

When you click again, the Add Case tool turns off. If you want to add several cases, repeat the
steps above. Or hold down the Alt (Win) Option (Mac) key as you add a case. As long as you hold
down this key, the Add Case tool will stay on.

If you add a new case into a binned, numeric axis, the case will be given the value of the lowest
value of the bin. So a case added to a bin of heights that ranged from 60 to 63 would be given
the value 60.

When you add cases to a numeric axis, they often don’t get the exact value you’d like. After
adding the case, you can edit the value in the data card or you can use the Drag Value tool
reposition it and change its value.

Draw on a Plot

You can draw on a plot to call attention to particular parts of the graph, to show a trend, to title
the plot, or to personalize it.

To draw on a plot,
1. In the lower plot toolbar, choose the Drawing tool.

¢

2. When you move the cursor into the plot, it will change into a pencil. Draw and release.

Note that when you release, the Drawing tool turns off. If you want to continue drawing, repeat
the steps above. Or hold down the Alt (Win) Option (Mac) key as you choose the Drawing tool. As
long as you continue holding down this key, the Drawing tool will stay on.

To erase drawings from a plot,

1. In the lower plot toolbar, click the small triangle to the right of the Drawing tool and
choose Clear Drawing from the menu.

Note that the Drawing tool has only one pen size and color (black). Also, if you resize a plot, the
drawing doesn’t rescale with the rest of the plot. So make the graph the size you want it to be
before drawing on it.

T7ip: On discovering the Drawing tool, some students may spend a lot of time drawing on their
plots. You may therefore wish to remove the Drawing tool from the lower plot toolbar using the
Toolbars submenu in the Plot menu. Note that this removes the Drawing tool only from the active
plot. If you open a new plot, the Drawing tool will be visible there.

Duplicate a Plot

You can make an exact copy of a plot. This is often useful when you’ve made a graph that you
want to save, but want to continue working from it rather than starting over from scratch. It’s
also useful if you want to make two similar graphs, say, one for males and the other for females.
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You could filter out the males, make a graph for the females, duplicate it, and then change the
filter to remove females.

To duplicate a plot,
1. Select the plot you want to duplicate.
2. Choose Duplicate Plot from the Edit menu.

Change Plot Toolbars

You can remove buttons and other options from the plot toolbars. You might want to remove
some features so that students just learning the program won’t be distracted by them. Or you
might want to remove the lower plot toolbar before printing so that it doesn’t appear along with

the graph.
To change the toolbars for a plot,
1. Select the plot you want to change.

2. Go to the Toolbars submenu of the Plot menu and choose the feature you want to remove

(or add back).
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Choosing Hide Upper Plot Toolbar or Hide Lower Plot Toolbar will remove all of the features on those
toolbars at once. To restore the toolbars, choose Restore Toolbars. You can also remove features one
at a time by scrolling to a checked feature and choosing it. A removed feature will appear
unchecked in the menu. To restore that feature, select it again.

Note that you can remove features from only one plot at a time.

Slow Down Animation

Sometimes it’s helpful for demonstration purposes to slow down the speed of an animation. To

do this,

1. Hold down the space bar while clicking one of the buttons that causes case icons to
move (Stack, Order, Separate, Mix Up, etc.).
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Making Common Graphs and Tables

This section describes how to make various graphs and tables. Each example assumes that you are
starting from a totally unorganized plot, such as the random display you get after clicking the Mix-
up button. For graphs of only one attribute, the example describes how to make the graph along
the horizontal axis, but you could make the same graph on the vertical axis. Also, for the most
part it isn’t necessary to follow the steps in the order listed.

Stacked Dot Plot

This graph shows how a numeric attribute is distributed while keeping each case clearly visible.
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To make a stacked dot plot,

1. Put a numeric attribute on the horizontal axis. From the data cards, drag the name of a
numeric attribute onto the horizontal axis of the plot (the lower part of the plot will
highlight to indicate when you can drop).

2. Fully separate the attribute. In the plot, drag any case icon all the way to the right (until
there are no bin lines). This will fully separate that attribute horizontally.

3. Stack vertically. In the upper plot toolbar, click the Stack Vertical button.

Dot Plot

This graph displays all the cases of a numeric attribute in a single line that runs parallel to the
axis. It is especially useful for comparing the distributions of several groups.
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To make a dot plot,

1. Put a numeric attribute on the horizontal axis. From the data cards, drag the name of a
numeric attribute onto the horizontal axis of the plot (the lower part of the plot will
highlight to indicate when you can drop).

2. Fully separate the attribute. In the plot, drag any case icon all the way to the right (until
there are no bin lines). This will fully separate that attribute horizontally.

3. Stack horizontally. In the upper plot toolbar, click the Stack Horizontal button.

In this example, the category attribute Grade was added to the vertical axis (drag the attribute
name into the left side of the plot) and the values of Grade were reordered (drag the value name
to the desired location).
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Frequency Bar Graph

This graph shows the counts for values of an attribute.
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To make a frequency bar graph,

1. Put an attribute on the horizontal axis. From the data cards, drag the name of an attribute

onto the horizontal axis of the plot (the lower part of the plot will highlight to indicate
when you can drop).

2. Stack vertically. In the upper plot toolbar, click the Stack Vertical button.

You can change the size or type of the icons using options on the lower plot toolbar. Here the
icon type is set to Fuse Rectangular to make solid bars. With numeric attributes, you can also
increase the number of bins by dragging an icon to the right.

Histogram

Histograms cluster cases of numeric attributes within intervals. They are especially useful when
you have a large number of cases.
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To make a histogram,

1. Put a numeric attribute on the horizontal axis. From the data cards, drag the name of a
numeric attribute onto the horizontal axis of the plot (the lower part of the plot will
highlight to indicate when you can drop).

2. Separate the attribute into bins. In the plot, drag any case icon to the right to create more
bins (up to eight); drag left to reduce the number of bins.

3. Stack vertically. In the upper plot toolbar, click the Stack Vertical button.
4. Fuse the icons. In the lower plot toolbar, choose Fuse Rectangular from the Icon Type menu.

You can fine-tune the interval width either by dragging the bin lines or by setting the interval

width.
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Value Bar Graph

Also known as a case-value graph, this graph displays the numeric value of each case as a bar of a
particular length. The length of the bar depends on the value of the case. In the example here, the
bar lengths correspond to the weight (in pounds) of each of 17 cats.
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To make a value bar graph,

1. Put a numeric attribute on the horizontal axis. From the data cards, drag the name of a
numeric attribute onto the horizontal axis of the plot (the lower part of the plot will
highlight to indicate when you can drop).

2. Set the icon type ro Value Bar Horizontal. In the lower plot toolbar, choose Value Bar Horizontal
from the Icon Type menu.

In the example, the bars are also ordered vertically by Weighr (with Weight selected in the data
cards, click the Order Vertical button) and the bars are labeled with the cats’ names (with Name

selected in the data cards, click the Label button on the upper plot toolbar and then set them to
display on the left).

Stacked Value Bar Graph

This graph displays the total of all the case values of a numeric attribute as a single bar. Each case
appears as a separate section of the bar. The example shows 13 male cats weighing a total of 157
pounds while 13 female cats weigh 128 pounds in total.

24
) 4
g M I
'E i
© F ﬁ 1
] T 1
0 a0 100
Weight {pounds)

To make a stacked value bar graph,

1. Put a numeric attribute on the horizontal axis. From the data cards, drag the name of a
numeric attribute onto the horizontal axis of the plot (the lower part of the plot window
will highlight to indicate when you can drop).

2. Set the icon type ro Value Bar Horizontal. In the lower plot toolbar, choose Value Bar Horizontal
from the Icon Type menu.

3. Stack horizontally. In the upper plot toolbar, click the Stack Horizontal button.

In the example, another attribute, Gender, was added to the vertical axis (drag the attribute name
to the vertical axis), the number of cases of each gender were displayed (click the Counts (n) button
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in the upper plot toolbar), and two reference lines were added to help you read off the length of
the two bars (click the Ref. Vertical button in the upper plot toolbar and access the menu to the
right of the button to add a second line).

Pie Graph

Pie graphs display cases as pie wedges. Pie graphs are useful for comparing the relative numbers
of values of various types. The example compares the proportion of male and female high school
students who have curfews set by their parents. Be aware that the size of the circle gives no
indication of the number of cases that are in it. A circle containing 100 cases will be the same size
as a circle containing one case. This is why it’s a good idea to display the number of cases in each
pie. (See Rectangle Graph for a similar type of display that does indicate different sample size.)
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To make a pie graph,

1. Set the icon type to Fuse Circular. In the lower plot toolbar, choose Fuse Circular from the Icon
Type menu.

2. Put an attribute on the horizontal axis. From the data cards, drag the name of an attribute
onto the horizontal axis of the plot (the lower part of the plot will highlight to indicate
when you can drop).

3. Color by another attribute. In the data cards, click the attribute you want to use to color
the pies.

4. Order the cases. In the upper plot toolbar, click an Order button to group cases of the
same value in the pies.

In the example, a color key was added (click the Key button in the upper plot toolbar) and the
number of cases for each gender was displayed (click the Counts (n) button in the upper plot
toolbar).

Rectangle Graph

Similar to pie graphs, rectangle graphs are useful for comparing the relative numbers of values of
various types. The example compares the proportion of male and female high school students
who have curfews set by their parents. One advantage rectangle graphs have over pie graphs is
that the size of the rectangle gives information about the number of cases it contains: the larger
the rectangle, the more cases that are in it.
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To make a rectangle graph,

1. Set the icon type to Fuse Rectangular. In the lower plot toolbar, choose Fuse Rectangular from
the Icon Type menu.

2. Put an attribute on the horizontal axis. From the data cards, drag the name of an attribute

onto the horizontal axis of the plot (the lower part of the plot will highlight to indicate
when you can drop).

3. Color by another attribute. In the data cards, click the attribute you want to use to color
the squares.

4. Order the cases. In the upper plot toolbar, click an Order button to group like cases in the
graph.

In the example, a color key was added (click the Key button in the upper plot toolbar).

Scatter Plot

A scatter plot allows you to explore the relationship between two numeric attributes with one
displayed on the horizontal axis and the other on the vertical axis.
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To make a scatter plot,

1. Put a numeric attribute on the horizontal axis. From the data cards, drag the name of a
numeric attribute onto the horizontal axis of the plot (the lower part of the plot will
highlight to indicate when you can drop).

2. Fully separate the attribute. In the plot, drag any case icon all the way to the right (until
there are no bin lines). This will fully separate that attribute horizontally.

3. Put a numeric attribute on the vertical axis. From the data cards, drag the name of a
numeric attribute onto the vertical axis of the plot.

4. Fully separate the attribute. In the plot, drag any case icon all the way up to fully separate
it vertically.

There is no option in TinkerPlots for displaying a line of fit on a scatter plot. However, you can
use the Drawing tool on the lower plot toolbar to draw a line (or curve) yourself. You can also
change the scatter plot into a binned scatter plot and use averages to help see a trend.

Often with scatter plots, two or more cases will lay exactly on top of one another because they
have the same values for both attributes. There is currently no option for “jittering” cases so that

you can see them or for creating special plotting symbols that stand for different numbers of
cases. There are a few things you can do, however.

To locate overlapping cases, you can pull an icon up and move it temporarily out of the way to
see if there are any hidden cases. You can also create bins for one of the attributes. Finally, you

can change the icon type to Fuse Rectangular, which will put cases that are close together or the
same value into rectangles in which you can see each individual case.
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Binned Scatter Plot

This graph shows a numeric attribute binned along the horizontal axis and another numeric
attribute, fully separated, on the vertical axis. The example shows the per capita income (in
thousands of dollars) of the 50 U.S. states and the percentage of each state who voted for George
W. Bush in the 2000 presidential election. This graph seems easier for people to interpret than a
scatter plot. And by adding the means of the bins (blue triangles), it provides a powerful way to
see general trends in the data.
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To make a binned scatter plot,

1. Put a numeric attribute on the horizontal axis. From the data cards, drag the name of a
numeric attribute onto the horizontal axis of the plot (the lower part of the plot will
highlight to indicate when you can drop).

Separate the attribute. In the plot, drag a case icon to the right to make two to eight bins.

3. Put a numeric attribute on the vertical axis. From the data cards, drag the name of a
numeric attribute onto the vertical axis of the plot.

4. Fully separate the attribute. In the plot, drag a case icon all the way up. This will fully
separate that attribute vertically.

In the example, the icons were stacked vertically (click the Stack Vertical button in the upper plot
toolbar), the mean was added (click the blue triangle Average button in the upper plot toolbar),
and a count was added to show the number of cases in each bin (click the Counts (n) button in the

upper plot toolbar).

Time Series Graph

Also known as a line graph, a time series graph shows how the value of an attribute changes over
time. The example shows the running time (in hours) for the female winner of the NYC
Marathon over roughly the last 30 years.
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To make a time series graph,

1. Put the time attribute on the horizontal axis. From the data cards, drag the name of the
time attribute onto the horizontal axis of the plot (the lower part of the plot will
highlight to indicate when you can drop).

2. Fully separate the attribute. In the plot, drag a case icon all the way to the right (until
there are no bin lines). This will fully separate that attribute horizontally.

3. Put a numeric attribute on the vertical axis. From the data cards, drag the name of a
numeric attribute onto the vertical axis of the plot.

4. Fully separate the attribute. In the plot, drag any case icon all the way up to fully separate
it vertically.

In the example, a line connecting the cases was added (choose Show Connecting Lines from the Plot
menu).

Dot Map

Some collections include attributes that measure the location of cases in some physical space.
With this type of data, you can make a map-like graph. The example shows the locations of the
capitals of 48 of the 50 U.S. states using their longitudes and latitudes. The case icons are colored
to show annual rainfall in each state.
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To make a dot map,

1. Put the attribute measuring the horizontal position on the horizontal axis. From the data
cards, drag the attribute name onto the horizontal axis of the plot (the lower part of the
plot will highlight to indicate when you can drop).

2. Fully separate the attribute. In the plot, drag a case icon all the way to the right (until
there are no bin lines). This will fully separate that attribute horizontally.

3. Put the attribute measuring the vertical position on the vertical axis. From the data cards,
drag the attribute name onto the vertical axis of the plot.

4. Fully separate the attribute. In the plot, drag a case icon all the way up to fully separate
that attribute vertically.

5. Color the plot by an attribute. In the data cards, click an attribute name to highlight it.
This will apply that attribute’s color scheme to the case icons.

In the example, a color key was added (click the Key button in the upper plot toolbar).
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Box Plot
The “box” part of a box plot shows the locations of the 25th, 50th, and 75th percentiles. The

box plot’s “whiskers” extend out to the end of the range. Box plots are particularly useful for
comparing attribute values for several different groups.

The example shows how much students” backpacks weigh as a percentage of their body weight.
These results are shown separately for students in grades one, three, five, and seven. The box
plots show that the older students tend to carry backpacks that are a higher percentage of their
body weight. They also show that there is more variability (spread) in how much students carry
at the higher grades than at the lower grades.
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To make a box plot,

1. Put a numeric attribute on the horizontal axis. From the data cards, drag the name of a
numeric attribute onto the horizontal axis of the plot (the lower part of the plot will
highlight to indicate when you can drop).

2. Fully separate the attribute. In the plot, drag any case icon all the way to the right (until
there are no bin lines). This will fully separate that attribute horizontally.

3. Add a box plot display. In the upper plot toolbar, click the small triangle to the right of
the Hats button and choose Box Plot from the menu.

In the example, the icons were stacked horizontally (click the Stack Horizontal button in the upper
plot toolbar), case icons were made very small (adjust the slider in the lower plot toolbar), and
another attribute (Grade) was added to the vertical axis (drag the attribute name from the data
cards to the left side of the plot). As an option, you can set the box plots to show outliers (choose
Show Outliers from the Hat Options menu).

Hat Plot

Hat plots divide a numeric attribute into three sections, a central “crown” and, on each side of
the crown, two “brims.” The brims extend out to the minimum and maximum values. In the Hat
Options menu, you can select among four options for how the crown of a hat plot is formed: based
on percentiles (the default), the range, the average deviation, and the standard deviation. The
example uses the percentile option.
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To make a hat plot,
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1. Put a numeric attribute on the horizontal axis. From the data cards, drag the name of a
numeric attribute onto the horizontal axis of the plot (the lower part of the plot will
highlight to indicate when you can drop).

2. Fully separate the attribute. In the plot, drag any case icon all the way to the right (until
there are no bin lines). This will fully separate that attribute horizontally.

3. Add a hat plot display. In the upper plot toolbar, click the Hat button.

In the example, the case icons were hid (choose Hide Icons from the Icon Type menu in the lower
plot toolbar) and an attribute (Position) was added to the vertical axis (drag the attribute name
from the data cards to the left side of the plot). You can drag the edge of any hat crown left or
right to set percentile-division points to different values.

Frequency Table

Frequency tables display the counts (and/or percents) of cases of various types. You can make
frequency tables for a single attribute, or for two attributes as in our example. The example shows
the numbers (and percents) of male and female high school students who have and don’t have a
curfew. The example show the values in two different colors to indicate how the percents were
calculated. Here the percents were based on the row totals, so they show what percent of males
(65%) and what percent of females (71%) have curfews.
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To make a frequency table,

1. Put an attribute on the horizontal axis. From the data cards, drag the name of an attribute
onto the horizontal axis of the plot (the lower part of the plot window will highlight to
indicate when you can drop).

2. Add counts and/or percents. In the upper plot toolbar, click the Counts (n) button and/or
the Counts (%) button.

3. Hide the case icons. From the Icon Type menu in the lower plot toolbar, choose Hide Icons.
(You could also adjust the Icon Size slider in the lower plot toolbar to make the icons very
small.)

In the example, the category attribute Sex was added to the vertical axis (drag the attribute name
onto the far left side of the plot).
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Making a Report

TinkerPlots has the basic tools necessary to write and print a report, but TinkerPlots is not a
word processor. If your report is long and complex, you will do better to copy your results from
TinkerPlots and paste them into another application designed specifically for report writing. For
an example of a report, see Backpack Report.tp, located in the Data and Demos | Demos folder.

Enter Text
1. Drag a text box from the object toolbar (upper left of window) into your document.
Text
2. Type in the text box. Resize the box by dragging a corner or an edge.
Here are some things to know about text boxes.
e Formatting options and a tool palette are available in the Text menu.
¢ You can have as many text boxes as you like in your document.

e A text box that is empty and not selected appears with a gray border around it to indicate
where it is.

e Generally it’s not a good idea to place a text box on top of a plot (to use as a title, for
example). When you select the plot, the text box will move behind it and be invisible. Place
text boxes describing the graph next to the plot.

Paste Pictures

You can paste pictures from other applications into TinkerPlots. If you are writing a report, this
might be a good way to illustrate parts of it.

1. Inanother application, copy a picture onto the clipboard.

2. Open a TinkerPlots document. Make sure that nothing is selected in your document.
(Click in an empty space to deselect all objects.)

3. Choose Paste Picture from the Edit menu.

You can resize the picture just as you would any other object in TinkerPlots by dragging the
edges of its frame.

You can also copy and paste pictures of TinkerPlots objects (for example, if you want several
static graphs that no one can change).

1. Select the object.

2. Choose Copy Picture from the Edit menu.

3. Click in an empty area of the TinkerPlots document (to deselect all objects).
4.

Choose Paste Picture from the Edit menu.

Copy Objects into Other Applications

You can copy objects from your TinkerPlots document and paste them into another application.
They will be pasted into the other application as pictures, not as dynamic TinkerPlots objects.

1. Select the object you wish to copy.
2. Choose Copy Picture from the Edit menu.

3. Switch to the application into which you wish to paste the picture, then choose Paste
from that application’s Edit menu.
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The picture you paste is not a live TinkerPlots object. If you change something in the original
TinkerPlots document that you want reflected in the other document, you’ll need to copy and
paste it again.
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Working with Formulas

You can use formulas to define attributes and to filter out cases from a plot. The following
sections describe some common applications of each of these uses.

Parts of the Formula Editor

This is the formula editor as it appears on a Macintosh platform.
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Use a Formula to Define an Attribute

You can use formulas to compute values for an attribute. For example, in a collection on
countries you might have the attributes Land_Area and Population. You could define a new
attribute, Population_Density, by writing a formula that divides Population by Land_Area.

Note: Creating a formula for an existing attribute deletes any values currently in that attribute.
First create a new attribute unless you want to replace your data with the calculated values.

To define an attribute using a formula,

... in the Data Cards

1. Enter the name of the new attribute into the <new attribute> cell at the bottom of the data
cards.

2. Double-click the circle in the Formula column. (If you can’t see the Formula column,
widen the data cards by dragging the right edge.)

3. Enter the formula into the formula editor and click OK. (See Enter a Formula.)

When you've added a formula, the circle in the Formula column of your new attribute changes to
blue, and the values of the attribute appear light gray rather than black. These changes remind
you that the values of this attribute are computed with a formula.
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...in a Case Table

1. Enter the name of the new attribute into the <new> cell, in the column head in the far
right of the case table.

2. Choose Show Formulas from the Table menu. A shaded row of formula cells appears.

RandomRectangles

length | width
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3. Double-click the formula cell under the attribute you want to define by formula.
4. Enter the formula into the formula editor and click OK. (See Enter a Formula.)

The computed values of the attribute appear light gray rather than black in the case table. This
reminds you that the values of this attribute are computed with a formula. To see the entire
formula in the formula row of the case table, you may need to make the cell taller or wider.

Use a Formula to Filter a Plot

You can use formulas to filter out cases from a plot. The filtered cases will still appear in the data
cards. To filter out cases,

1. Select the plot and choose Add Filter from the Plot menu.

2. Enter a formula in the formula editor that specifies which cases you want to keep in the
plot and click OK. (See Enter a Formula.)

Enter a Formula

When you open the formula editor, the cursor is in the formula pane. To enter a formula, type in
the formula pane, click buttons on the keypad, or use the attribute and function list. Most likely
you’ll use a combination of these methods. Here are a few suggestions that will come in handy.

e Click on an item to get an explanation of it in the help pane at the bottom of the formula
editor.

e When things don’t work the way you want, use parentheses.

e The up-arrow key is very useful when you want to understand the structure of an
expression.

e The formula editor is 7oz case sensitive. You can type all lowercase, and TinkerPlots will
interpret your expression correctly. For example, Round works as well as round.

e When you have correctly typed an attribute name, it turns blue.
e When you have correctly typed a slider name, it turns magenta.

e Type * (Shift+8) for multiplication, / for division, and * (Shift+6) for exponentiation. When
you've typed an exponent, use the right-arrow key to exit it.

e Enter 7 by typing pi. As soon as you type an operator or press any of the arrow keys, the
symbol 1 appears in place of “pi.”

e When you type the left parenthesis for a correctly spelled function, the function name
turns red.

e When you type an open parenthesis, TinkerPlots gives you both open and close
parentheses, with the cursor between them. You can simply begin typing. To exit the
parentheses, type a close parenthesis or use the right-arrow key.

e Multiplication is sometimes indicated as a dot between terms and sometimes, as in
traditional algebra, as nothing between terms (though you need to put the asterisk in).
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e When you type an open quote, TinkerPlots gives you both open and close quotes, with the
cursor between them. You can simply begin typing. To exit the quotes, type a close quote
or use the right-arrow key. You must use quotes to enter string values in formulas (such as
“rich” in the following example).

wealth formula

if [income > IDDDDE]{::riCh""
poor

e When you type 1£f ( you get a complete (though empty) if-statement, with three parts for
you to fill in (as shown below). Type the condition (in the example above, income >
100000), then use Tab to move to the results (result-if-true goes on the top, result-if-false
on the bottom). If you want the results to be words (also known as strings), you must
surround them with quotation marks. (See Make If- and Switch Statements.)

wealth formula

L m{;

e When you have more than two results, instead of nesting if-statements, you can use the
switch function. This is useful for recoding attributes. The switch function takes an optional
expression inside parentheses and then evaluates each of any number of true/false
expressions to determine which value to return. To add an alternative, press Insert (Win)
Command+Option+Return (Mac) on your keyboard. (See Make If- and Switch Statements.)

Apply the Formula
You cannot do other things in TinkerPlots with the formula editor open.

e The Apply button causes the formula to be stored and evaluated, but does not close the
formula editor. This can be very helpful when you are not sure how to get the formula you
want or when you want to try different options.

e The OK button causes the formula to be stored and evaluated and closes the formula editor.

e The Cancel button closes the formula editor without changing the formula from what it was
the last time you applied changes.

Adjust the Formula Editor Panes

When you want to see more of various portions of the formula editor, for example, when you
have a tall formula or you want to see more of the formula list, you can adjust the size of the
formula pane and help pane by dragging their borders. For example, you might have a very tall
formula or you may want to see more options in the attribute and function list.

Cancell apply I Ok ‘
Use the Keypad
Click the number and symbol buttons in the keypad to enter them into a formula. Everything

that can be entered from the keypad can also be entered by typing on your computer’s keyboard.
When you press Ctrl (Win) Option (Mac), you can see alternative buttons in the keypad, such as 2.

=

=
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Use the Attribute and Function List

Enter parts of your expression by double-clicking on items in the attribute and function list. This
is handy if you have long attribute names or if you can’t remember exactly how to spell a
particular function.

e To see alist of choices in a given category, click the open/close control next to it. Here the
user is about to open the attributes list.
¥
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e To enter an item from the list into the formula, double-click it.

e To close a list, click the open/close control.

e To see an explanation of an item, click it once to select it. You can then read about that
item in the help pane at the bottom of the formula editor. This is especially handy if you
can’t remember the exact syntax for a function.

Move the Cursor and Select a Portion of an Expression

Moving and positioning the cursor in the formula editor can be tricky. Here are some tips for
getting what you want to happen.

e Generally you can click the mouse where you want to position the cursor, but when that
fails, try the right- and left-arrow keys either on the formula editor keypad or on your
computer keyboard.

e Ifyou are inside a parenthetical expression, typing a right parenthesis, ), will move the
cursor to the right and outside of that expression.

e Ifyou are inside a quoted expression (a string), typing a double quote will move the cursor
to the right and outside the quoted expression.

e Pressing the Tab key will select the next portion of the expression. It’s particularly helpful
when you have if- or switch statements and you want to get to the next section.

e The up-arrow keys on the keypad and the computer keyboard will select the next largest
portion of the expression starting from the current selection. (For example, pressing the up-
arrow key several times will generally select the entire expression.)

e The down-arrow keys on the keypad and the computer keyboard will select the next
smallest portion of the expression. (This is less useful than the up-arrow key, because it is
hard to predict which smaller expression will be selected.)
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Copy and Paste Formulas

e To copy an attribute formula without opening the formula, click the attribute name and
choose Copy Formula from the Edit menu.

e To paste an already-copied formula into an attribute, click the attribute name and choose
Paste Formula from the Edit menu.

Note: To remove a formula entirely, choose Clear Formula from the Edit menu.

Make Boolean Expressions

Boolean expressions are expressions that can either be true or false. They are useful in creating
filters. For example, if you’re looking at population data and you want to find women over 60
who are either married or divorced, then the expression below will filter out from the plot any
people in the census file that do not fit this category.

fze = "F"vand (age> 600
and ¢ ¢ marital = "Mar"y or {marital = "Div"y
Here are some tips for making Boolean expressions.

e The comparison operators =, <, and > can be found on the formula editor’s keypad. You
can also find <, >, and # on the keypad by pressing Ctrl (Win) Option (Mac). You can also
enter all of these from the computer keyboard.

e Express the 7oz of an expression (the negative of an expression) by positioning the cursor in
front of the expression and clicking the not key on the formula editor keypad.

*  You can use and and or to string logical expressions together. Click the buttons on the
formula editor keypad to enter these. Typing the words from the computer keyboard does
not work.

¢ Some keyboard shortcuts: & for and, Ctrl+Shift+O for o7, and ~ for not.

e When in doubt about which expressions are evaluated first, use parentheses to force the
evaluation order you want.

e True and false are allowed values for attributes, so you can enter a formula for an attribute
that returns a Boolean value.

Make If- and Switch Statements

Many times you would like the value of an attribute to depend on whether something is or is not
true of another attribute. That’s when you use an if-statement. If you have more than two
possibilities, use a switch statement.

If-Statements

An if-statement has three parts: the condition, the value when the condition is true, and the value
when the condition is false.

value when true *\

if ¢ lceream = “chocolate™ {:3”'“"

k™
condition —/ 7
value when false

To create an if-statement,
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1. Typeif (. As shown below, TinkerPlots fills in the other parenthesis, the brace, and a
question mark for each of the values to be entered.

if ¢ }{:
Or,

1. Open the function list to the Conditional category and double-click #f-

You can create nested if-statements by using if-statements as values for if-statements.

if e = "fude™ "’E’*;t”‘r;'

if ¢ loeCiream = “shocolate™ e .
i ¢bour » 83 {..EE'* It &y

Pass

Switch Statements

Switch statements are very helpful for recoding data. Switch statements, unlike if-statements, can
deal with more than two possibilities.

There are three parts to a switch statement: the value to switch on, the test values, and the result
values. Usually you will write switch statements similar to the one shown here. Your value to
switch on will be the name of an attribute, the test values will be values that the attribute takes
on, and the result values will amount to a recoding of the original attribute. TinkerPlots returns
the result value whose test value matches the value being switched on.

test values *\ /— result values

{ "chocolate™ @ “good”

: i vanilla™) :"Ok"
switch ¢ flavary strawberny™ sk
value to_/ else : "reutral”

switch on

A switch statement’s tests are not limited to equality. In the statement below, for example,
TinkerPlots first compares the value of N with 0 and returns “zero” if /V does equal 0. If not, it
tests to see whether /Vis less than 5 and returns “low” if it is. If not, it goes on to compare N with
10 and returns “medium” if NVis less than 10. If no test has succeeded thus far, it returns “high.”
(0% o -
_ (a5 Mo
SR CN3 902 10y : “medium®
elze : "high"

Here are the rules to keep in mind when writing switch statements.
e Ifyou do not explicitly specify a comparison operator, TinkerPlots will test for equality.

e TinkerPlots returns the first result value whose test returns true. The fact that later tests
might also return true has no effect on the result.
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e A switch value can itself be an expression, not just the name of an attribute, for example,

circum . .o .
—————. The result of evaluating the expression is used in the test.

(T amy ;o Mlesthan”

switch M (D : equal”
[diarreter] el se - "greater than”

diameter

e Result values may be any expression (including if- or switch statements).

e The switch value is substituted for any question marks or missing arguments to functions
that appear in the test expression.

Common Uses of Formula-Defined Attributes

Here we describe several common uses of formula-defined attributes.

Convert Measurement Units

You may want to change the unit of measurement of a numeric attribute, for example, feet to
meters. In the data set Backpacks.tp, the attributes Body Weight and PackWeight are both given in
pounds. You might want to convert these to some other unit, such as kilograms. A pound is
equivalent to 0.4536 kilograms, so you can create a new attribute by using the conversion
formula.

WeightkKg formula
WeightkKg = weight-0.4536

Tl al al &l =1 [b attributes

Create Derived Attributes

Often it’s helpful to create new attributes from existing ones. For example, the data set US

Students.tp includes attributes for the number of older siblings (OLDSIBS) and younger siblings

(YOUNGSIBS). From these we created the new attribute #children by using this formula.
#children formula

*children = \OUNGSIES + OLDSIES + 1

7l al al «1 = [P attributes

Recode Numeric Values to Categories

Sometimes it’s useful to make a category attribute from a numeric one. For example, in the data
set US States.tp, the numeric attribute /nternetAccess shows the percentage of people in each U.S.
state who have Internet access. We created a new attribute that divides the states into three
groupings: states with low Internet access (below 49%), states with medium Internet access (49%
to 55%), and states with high Internet access (56% to 100%). To do this,

1. Define a new attribute called /nternetLevel.

2. Give it the formula shown here.
InternetLevel formula

Internetlevel = P49y o

) ?+<56) :"medium”
witch ¢ Infernetboressy E?S 10)0) - "high"

HES

7lialal i+l =1 TF siributes a

The switch function is very useful for doing this kind of recoding. In this case, the switch
function starts from the top and substitutes the attribute /nzernetAccess for ? in each of the
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expressions, searching for an expression that is true. When it finds one, it stops and returns the
value to the right of the colon for that expression. By specifying “else” as “” at the bottom of this
list we accounted for the possibility that one or more of the cases might have a missing value.
Tips for entering this formula:
*  You do not type the ? characters; TinkerPlots enters them for you when you start typing
the characters into the parentheses.
e Toenter <, press Ctrl (Win) Option (Mac) and click the < button on the formula editor
keypad.

e To get a new line in the switch statement, press the Insert key on your computer keyboard
(Command+Option+Return also works on a Macintosh).

e Remember to put the category values, like “low,” in quotes.

e Ifyou get too many lines in your switch statement, you can get rid of them by pressing the
Delete or Backspace keys until there is nothing left in the line.

Recode Missing Values

Most real-world data have missing values. TinkerPlots treats empty values (nothing in the cell) as
missing. Unfortunately, there is no standard way for coding missing data, so you’ll often import
data that uses an asterisk * for missing data, or the word “missing.” For TinkerPlots to treat these
as missing, you’ll need to recode the data.

Suppose, as shown in the left column of this case table, that an attribute named #hickness has
missing values coded as asterisks, *.

thickness | thicknessRecode
4 4

] z

2 2

4 4

*

2 2

1 1

We want to recode the asterisks as empty values and leave everything else intact. To do this,
1. Make a new attribute named thicknessRecode.

2. Give it the formula below.

if [izkumber (thickness)) {thickness

You can see the result in the second column of the case table. The formula says that if the value
of thickness is a number, then keep that value. But if the value of #hickness isn’t a number, then
replace that value with nothing ().

If you want, you can then delete the formula for thicknessRecode, and then delete the original
thickness attribute. You might then rename thicknessRecode to thickness.

Round Data

Many data sets include attributes with decimal values. You may want, however, to use one of
these data sets with students who have not yet learned about decimals. If the data set is short, you
could edit values by hand. But if the data set is longer, it would be quicker to create new
attributes using the round function.
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For example, in the data set Dinosaurs.tp, the attribute Height includes decimal values. You could
make a new attribute, HeightRound, that rounds values of Height to the nearest whole number by
using this formula.

HeightRound formula
HeightRound =| round ¢ Height s

=l alial Wl DT aviiaa

After creating the new attribute, you would probably want to remove the original attribute. To
do this, first open the formula for HeightRound and delete it. This will leave the computed values
in place. Now you can delete the attribute Height. You might also want to change the name of
the new attribute from HeightRound to just Height and perhaps move it from the bottom of the
data card to where the original attribute was.

Note that you can specify the number of decimal places to round to. Entering round
(height, 1) would round the values to one decimal place.

Transform Time-Coded Data

Often when you download data with a time attribute, the times will be represented as a string.
For example, 08:04:55 means 8 AM, 4 minutes, 55 seconds. Because values in this attribute
contain non-numeric characters (the colons), TinkerPlots will consider this a category attribute.
There are a number of different ways to recode such time data to make them numeric, and which
you use will depend on what information you want to keep and in what form. You may want
three attributes: Hour, Minute, and Second, or you may want to convert the times into decimal
hours. In either case,

1. Suppose your original attribute is called 77me. Create three new attributes: Hour,
Minute, and Second.

2. For the attribute Hour, enter the following formula into the formula editor.

Hour formula
Hour = ||l=ftString ¢ Time, 23

Flalal &l =1 [F attribut

The function leftString in this case begins at the beginning of each value of 77me and
returns the first two characters, which is the hour.

3. For the attribute Minute, enter the following formula into the formula editor.

Minute formula
Hinute = midString (Tire, 4, 2%

Zzlalal ol =1k attrintes

The function midString starts at, in this case, the fourth character in the string and
returns it and the next character (in the formula, the 4 after 77me is the beginning point,
and the 2 says how many characters to go to the right).

4. For the attribute Second, enter the following formula into the formula editor.

Second formula
Second = ||rightString ¢ Time, 23

Zl ol ol Ll =1 IE s
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The function rightString begins at the end of the string and returns, in this case, the first
two characters.

Here is an example of what your data might now look like, with the original attribute, and the
three newly created attribuces.

Tirne Cata

02 :04 .35

09:130z2 |9 13 2

10:01:34 |10 1 z4
10:36:44 |10 a6 44
112724 (11 27 24

You might now want to make a single time attribute that gives the hour and fraction of the hour
in decimal form. To do this,

1. Create a new attribute, T7me2.

2. Define Time2 using the following formula.

Time2 formu

In an hour, there are 60 minutes or 3600 seconds, so this formula gives you a measure of
time expressed in hours only, where the decimal portion tells you the fraction of the
hour. In this format, 30 minutes would be expressed as 0.50 hour. Here’s what the case
table would look like now.

2.02194

02:04:55

09302 |39 13 2 21722
10:01:34 |10 1 34 100261
105644 |10 SE 44 10,9456
112724 |11 27 24 11.4567

You may want now to delete all the other time attributes except 77me2. However, you'll first
need to delete the formula for 77me2. To do this,

3. In the data card, double-click the blue formula circle for 77me2.
4. Highlight the formula in the formula editor, then press Delete.
5. Click OK.

Deleting the formula for 77me2 leaves its values in place, but they will no longer be dependent
on the other attributes. If you tried first to delete one of the attributes that 7ime2 uses in its
formula, TinkerPlots wouldn’t know how to compute values for 77me2.
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Create Realistic Data

TinkerPlots has a lot of functions you can use to make up data for instructional purposes.
Suppose, for example, you want sample data that are approximately normally distributed with a
particular mean and standard deviation. You can quickly generate a large sample using the
function randomNormal. Here, for example, is how you’d make a group of 100 students who
were 60 inches tall on average with a standard deviation of 2.5 inches.

Create a new data set by dragging a stack of data cards into the document.
In the data cards, enter the attribute name Heighz.
Choose New Cases from the Data menu.

In the dialog box, enter the number of new cases to add and click OK.

A e

In the data cards, double-click the circle in the Formula column. (If you can’t see the
Formula column, widen the data cards by dragging the right edge.)

6. In the formula editor, type the following formula and click OK.
Height formula

Height = |randomMNormal (60, 2.5

Tl alal «l=1 1k atribut

TinkerPlots will assign random values to the 100 cases by randomly drawing from a normal
distribution with mean of 60 and standard deviation of 2.5.

Rather than entering fixed values for a function like this, you could enter the names of sliders in
their place. With the randomNormal function, for example, this would allow you to dynamically
change both the value of the mean and the standard deviation and watch the data in the graph
change as you do it. To enter slider values into the above attribute formula, you’d create two
sliders, one named Mean and the other SD (see Make a Slider). In the formula editor, you’d enter
these slider names instead of values. In this case, here is what the formula would look like.

Height formula
Height = randomMormal ¢ Mean, S0

=l al al vl =l Th i

The Data and Demos | Demos folder contains several files that use this approach to create realistic
data that you can manipulate with sliders to make up data of various kinds. See, for example,
Sample Means Demo.tp or Medical Test Demo.tp.
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Working with Sliders

A slider is a named value that you can use in the formulas of attributes and of plot filters. You can
dynamically change a slider’s value and thus the data values dependent on it. See Common Uses

of Sliders.

Make a Slider

1. Drag the slider from the object toolbar (upper left of window) into the document.

By default, sliders are named VI, V2, etc., have an initial value of 5, and have an axis that goes
roughly from 0 to 12, as shown here. On this slider, the cursor is near the slider’s “thumb.” Drag
the thumb to change the slider’s value, or click the arrow to animate the slider.

[}?1 =5.00
=,

Rename a Slider
1. Double-click the name (V1) and type a new one. Then press Enter.

T7ip: Use meaningful slider names to make it clear what purpose each slider serves. Each name
must begin with a letter and contain only letters, numbers, or underscores (_). Any invalid
characters are removed when you press Enter.

Change a Slider’s Value
1. Drag the slider thumb to a new position on the axis.
Or,

1. Double-click the numeric value to the right of the equal sign and type a new value. If
necessary, the axis will change to include the value.

Change a Slider’s Scale
To change the scale of a slider axis,
1. Move the cursor over the axis. The cursor will turn into a hand icon.

2. Move the hand either to the center of the scale or to one of the ends. In the center, the
fingers of the hand will point up. Towards the ends of the axis, the fingers will point to
the right (right end of scale) or to the left (left end of scale).

3. Click and drag to adjust the axis. Pulling from the center (fingers up) will translate the
axis, moving it left or right without changing the scale. Pulling in or out from one of the
axis ends will rescale the axis, making the axis values either closer together or farther
apart.

Or,
Double-click the axis to bring up the Inspect Slider window, shown here.

2. Enter new values for Lower or Upper to change the axis endpoints.
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3. Click the close button to close the window.

& ] Inspect Slider
Froperties
Property Yalue
¥i 1

HMax_updates_per_second

Lower u]

Upper 29.4573F

Restrict_to_multiples_of

Animate a Slider

1. Click the arrow button on the slider (to the left of its name). The button changes to an x
button. Click again to stop animation.

=

The slider thumb will move back and forth between the ends of the slider axis, and the value
corresponding to the slider will change accordingly. Any formula containing the slider’s name
will be recalculated and all views of it will update. The direction the slider goes first depends on
the direction it was last moving. If you want it to first animate to the right, move it manually to
the right before you start the animation.

While an animation is taking place, you can do other things in TinkerPlots, but the response
might be a bit slow. You can slow down animation by making the slider wider, or speed it up by
making it narrower. You can also change its speed by entering a value for Max_updates_per_second
in the Inspect Slider window. To open this window, double-click the slider axis. Higher numbers
speed up the animation.

Restrict Slider Values

You may want a slider to allow only certain values, integers for example. To restrict slider values,
1. Double-click the slider axis to open the Inspect Slider window.

2. Enter a value into the Value column for Restrict_to_multiples_of. Entering the value 1 creates
an integer slider, entering 10 creates a slider that gives only multiples of 10 as its
values—even when you animate or drag the slider.

Use a Slider in a Formula

You can refer to a slider’s value in any formula. When you create the formula, either type the
slider’s name, or double-click its name in the Global Values list in the formula editor.

Common Uses of Sliders

Here we describe a few possible uses of sliders in TinkerPlots. The folder Data and Demos | Demos
includes several TinkerPlots files that use sliders in various ways. As you’ll see in those
documents, sliders are easy to use once they have been created. But useful sliders are not so easy
to set up in the first place. Thus sliders are not things that students themselves should in general
be figuring out how to construct. Rather, they are resources for teachers and curriculum designers
to use in creating data sets and activities for students.

TinkerPlots Help
© 2005 University of Massachusetts

76



Animate Time Series Data

Many data are collected over time. For example, the data set NY Marathon.tp includes the running
times for the male and female winners of the New York City Marathon from 1970 through
2004. Plotting data such as these over time often reveals interesting patterns and trends. You can
use plot filters and sliders to “re-enact” such events that occur over time. This allows you to add
data to the plot over time. Results are much like time-lapse photography. These time animations
can help students learn how to read time series plots (by scanning visually from left to right along
the time axis). The animations can also help you detect subtle patterns in the data that are hard
to see when you view them all at once.

To create a slider that allows you to add data to a plot in the order they were collected,

1. Make a time series graph, putting the time attribute on the horizontal axis and the
attribute you want to view over time on the vertical axis. Fully separate each attribute.

nyrnarathon |
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2. Create a slider that will control time (in this case, Year). To do this, drag a slider from the
object toolbar (upper left of window) and drop it where you want in the document.
Here it is right below the plot. By default, the name of the slider will be V1. Double-
click the V1 and rename the slider (in this case, VaryYear).

3. Set the slider axis. Double-click the slider axis to open the Inspect Slider window. Set the

Lower and Upper values so that they include the full range of your time attribute. Because
the values of Year are integers, enter 1 into the value for Restrict_to_multiples_of. Now the
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slider will take on only integer values. Click the close button of the Inspect Slider window
to close it.

(&) Inspect Slider

Properties |

Property Yalue

YaryYear 1986

Hax_updates_per_second

Lower 1970

Upper 2005

Restrict_to_multiples_of

4. Add a filter to the plor. With the plot selected, choose Add Filter from the Plot menu. Type
a formula that will allow you to control the cases that appear in the plot with the slider.
After you've entered the formula, click OK.

This example shows the filter formula Year < VaryYear. The formula instructs
TinkerPlots to include in the plot only the values of Year that are less than or equal to
the current value of the slider VaryYear. To enter <, press Ctrl (Win) Option (Mac) and
click the < button on the formula editor keypad.

5. Set the plot axis. To prevent the plot axis from automatically rescaling as data are added
or removed, click the upper value of the time-based plot axis and set the axis endpoint to
some value that is greater than the maximum data value.

(IS TRNSTIEN ]

Edit Axis

Axis ends at 2005

Bin width 0

Cancel ( oK 3

1930 1930 2000

*I
—

Year

6. Use the slider to control the plot. Do this either by dragging on the slider’s thumb or by
clicking the arrow next to the slider name to animate the slider. Click the red X to stop
the animation.

In this example, when you add the data to the plot over time, you clearly see that the winning
times for males and females tend to go up and down together from year to year, perhaps
reflecting the effect of weather conditions on run-times. This relationship is not as easy to detect
when all the data are on the graph at once.

Grow a Sample

When looking at a sample to explore a particular question, students will often ask, “But what
would happen if we collected more data?” One way to let young students explore this question is
to “grow” samples—to randomly draw cases from a larger population and observe how the
sample changes, and doesn’t change, as it gets larger. Though you can do this with real data, the
example here uses made-up data.

Open the demonstration document Fish Experiment Demo.tp to see the data. The cover story
involves a fish farmer who has stocked a pond with both normal fish and a new type of
genetically altered fish that is supposed to grow longer than the normal fish. To test this claim,
the farmer catches the matured fish from the pond and measures them. The demonstration
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allows you to capture data from the collection and display it in a plot. Use the slider beneath the
plot to gradually increase the sample size until, if you want, you can view all 625 fish in the
pond.

When students in grades 4-6 have used these data both on and off the computer, they have come
to observe that even when their sample is still relatively small, certain features of the larger
population are usually already evident, such as where the data tend to be centered.

The following steps describe how this document was set up using sliders, filters, and attribute
formulas.

FishExzperiment |
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1. Create a slider that will allow you to add data to the plot. To do this, drag a slider from the
object toolbar (upper left of window) and drop it where you want in the document.
Here it is below the plot. By default, the name of the slider will be V1. Double-click V1
and rename the slider, (in this case, Samplesize).

2. Set the slider axis. Double-click the slider axis to bring up the Inspect Slider window, as
shown. Set the Lower and Upper values to cover the range of the number of cases, in this
example from 0 to 625. Enter 1 into the value for Restrict_to_multiples_of so that the slider
will take on only integer values. Click the close button of the Inspect Slider window to
close it.

8 Inspect Slider

[:} Samplesize =60

100 200 Samplesize
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3. Add a filter to the plot. With the plot selected, choose Add Filter from the Plot menu. Type
a formula that will allow you to control the cases that appear in the plot with the slider.
After you've entered the formula, click OK.

This example shows we entered the formula CaseNo < Samplesize. The attribute CaseNo
ranges from 1 to 625, and each case has a unique number. This filter formula instructs
TinkerPlots to include in the plot only the values of CaseNo that are less than or equal to
the value of the slider Samplesize. Thus by adjusting this slider, you can grow the sample
all the way from 0 case to 625 cases. (To enter < into the formula editor, press Ctrl (Win)
Option (Mac) and click the < button on the formula editor keypad.)

Edit Filter

Caz=Mo 2 Samplesize

Tlhiglal ==l Tk atributes

4. Set the plot axis. To prevent the plot axis from automatically rescaling as new values are
added, click the upper end of the plot axis. In the dialog box, enter the value 45 even
though it was already set to this value. By retyping it into the dialog box, you lock that
end so it won’t change. Do the same for the lower end of the axis, setting it to be below
the minimum value of the data.

r Edit Axis

Axis ends at 45

Bin width 0

{ Cancel ) E OK )

20 25 0 35 40 45
Length (cm)

5. Use the slider to control the number of cases in the plot. Do this either by dragging on the
slider’s thumb or by clicking the arrow next to the slider name to animate the slider.
Click the red X to stop the slider animation.

In this example, the attribute Case/No was created using a formula that allows you to quickly
reassign case numbers to the 625 values. Thus you can redo this experiment over and over, seeing

what happens if the fish happened to be sampled in a different order.
To randomly assign new values of CaseNo to the cases,
1. Choose Rerandomize from the Data menu.
If you have data in the graph, you’ll see it change location as a new sample of fish are “caught.”

Here’s the formula for Case/No we use to do that.

CaseMo formula

CaseMo = |uniqueRank ¢ random ¢ 33

The formula combines two functions. The inner-most function, random(), randomly assigns each
case a real number from 0 to 1 (the default range for this function). So each case in the data set
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gets some value such as 0.56779. The function unigueRank then takes these random numbers
and assigns them a unique ranking from 1 to 625 (the number of cases we have) based on their
value. If two or more of the cases happened to have random numbers of the same value, which
would be extremely unlikely, the function uniqueRank will arbitrarily give them unique rankings

anyway. This is all just a complicated way of randomly reordering the 625 cases and giving them
a number based on this ordering.

Create a Random Sample

Sometimes data sets you’ll download from the Internet will be much larger than you want. You
could, of course, just delete a bunch of the cases. However, cases are often not entered into a data
set in random order, so keeping only, say, the first 200 cases may give you a biased sample.

To create random samples from a larger data set, you follow the same basic procedure described
in Grow a Sample. The advantage of using this approach is that you won’t need to throw away
any of the data if you don’t want to. Rather you set it up so that you can look at random samples
of the data, and these samples can be of any size you choose. But before you can draw samples as
described in Grow a Sample, you’ll first need to create a new formula-defined attribute in the
data card. Here’s how.

1. In the data cards, click <new attribute> at the bottom of the data cards and enter a name

such as CaseNo.

2. Double-click the circle in the Formula column for this new attribute. (If you can’t see the
Formula column, widen the data cards by dragging the right edge.)

3. In the formula editor, enter the formula uniqueRank(random()) and click OK. See Enter
a Formula for help.

This formula assigns a random set of case numbers to all of your cases.
If you do want to delete some of the cases after creating a random ordering, here’s how to do it.

1. Inaplot, separate the cases according to the attribute that assigns cases a random order.
This is the attribute Case/No in our example.

2. Make bins so that the label at the right of one of the bins is the same as the number of
cases you want to keep.

3. Select the cases you want to delete from the data set by drawing a marquee around those
cases. In the example below, we've selected all of the cases with values of Case/No greater
than 125. The color gradient is off so that you can clearly see the selected cases, but it
doesn’t need to be.

120 -
-
=
2 en-
(1]

|:|_

0-123 126-231 292-377 375-503 S04-623

CazeNo
4. In the data cards, click the gray circle at the top of the data cards. (If you click
somewhere else in the data cards, you will deselect the cases.)

5. Choose Delete Cases from the Edit menu. The selected cases will be removed from the data
set.

6. Choose Save As from the File menu to save this new, smaller data set as well as the
original one with all the data. Choose Save from the File menu to replace the original data
set with this new one.
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Create Realistic Data
You can use a slider along with formula-derived attributes to create and quickly modify
hypothetical data. See Create Realistic Data in the section Common Uses of Formula-Defined

Attributes.
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TinkerPlots Objects

There are six different kinds of objects you can place in a TinkerPlots document: data cards, case
tables, plots, sliders, text, and pictures.

You can create a new object by dragging its icon off the object toolbar located in the upper-left
corner of the TinkerPlots window. Place the object in the document where you want it to appear.
Reposition an object by dragging it by its top bar. Resize an object by dragging from a corner or
edge.

Several objects have their own menu in the menu bar at the top of the window. These menus are
visible only when the object is selected.

Most objects also have a contextual menu that you can activate by right-clicking (Win) or by
pressing Control and clicking (Mac).

Delete an object by selecting it and then choosing Delete [object name] from the Edit menu or by
using the keyboard shortcut Del (Win) Command+D (Mac). You can also temporarily hide objects
by choosing Hide [object name] from the Edit menu and bring them back into view by choosing Show
Hidden Objects from the Edit menu.

You can turn most objects into icons by dragging from the lower-right corner all the way up and
left. Turning an object into a icon allows you to move large objects temporarily out of the way.
When you want to see the object again, enlarge it by dragging a corner.

You can place any object in its own, floating window by choosing View In Window from the Window
menu.

Data Cards

In TinkerPlots, data sets are stored in a stack of data cards. With data cards you can see one case
at time, add or change data, drag attributes into plots, and change the color scheme of attributes.
You can use other objects, namely case tables and plots, to see your data displayed in other ways.
If you delete a case table or plot, the data remain in the data cards. But if you delete the data
cards, the data are gone.

Click to select case;
Drag line to adjust column width.  click outside circle to deselect.

\ |
\ &}ca5e1af?91“

Click arrows to move

Click to deselect ———— through cases.

all attributes

1 Name Angie Click cell to
Click attribute name to — [ ] Gender F enter/edit value.
select; double-click to edit. \[[l’[irade One
Drag to plot axis to graph. [ BodyWeight 45 Click cell to enter/edit
[ Pack¥Weight 4 ) attribute unit
Double-click attribute ——— [ Percentw't @ Double-click circle to

color bar to edit color
scheme.

[ <new attribute: enter/edit attribute

formula.

e DPress Tab to move down a column of values or units. When you’re at the bottom row, Tab
moves you to the next data card.

e Press the Home key to go to case 1; press the End key to go to the last case.

e Drag the lower-right corner to resize the stack.
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Attributes in Data Cards

To make a plot using an attribute, drag that attribute’s name to a plot axis.

To select an attribute, click that attribute’s name. When an attribute is selected, the icons
in a plot are colored with that attribute’s color scheme.

To change an attribute’s color scheme, double-click the color bar next to that attribute’s
name.

To deselect all attributes, click the light blue color bar at the upper left of the data cards.
Clicking here also colors all case icons the same, light blue color. This is especially useful
for seeing highlighted icons in the plot, as highlighted cases will be colored red.

To add a new attribute, double-click in the bottom row labeled <new attribute>.
To rename an attribute, double-click its attribute name.

To delete an attribute, click it once to select it. Then choose Delete Attribute from the Edit
menu.

To insert an attribute in a particular position, select the attribute in the row below where
you want the new one to appear, then choose New Attribute from the Data menu.

To enter or edit the unit name of an attribute, click in a cell in the Unit column.

A blue circle in the Formula column indicates an attribute that is computed by formula.
Double-click the blue circle to see or edit the formula. Double-click a white circle to create
a formula for an attribute.

Cases in Data Cards

To bring a particular case to the top of the stack, click the arrows in the upper-right corner;
or click the case’s icon in a plot.

To select a case, click the colored circle at the upper right of a card; click next to the circle
to deselect the case.

To enter data for a new case, go to the last card in the stack. (Press the End key to go
directly to the last card.)

To edit data for a case, click a cell in the Value column and enter the new value.

To delete a case, click the colored circle at the top of the card to select the case. Then
choose Delete Case from the Edit menu.

To enter or edit the attribute value of a case, click a cell in the Value column.

Case Tables

Case tables display data in a table format, with attribute names along the top of the table and
each case in a separate, numbered row. With a case table you can see multiple cases at once, add
or change data, drag attributes names into plots, and sort your data.

TinkerPlots Help
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Press Tab to move to the next cell; press Enter to move down one row.
To see the formula row (as above), choose Show Formulas from the Table menu.

Resize the formula row by dragging the bottom of its row.

Attributes in Case Tables

To make a plot using an attribute, drag that attribute’s name to a plot axis.

To select an attribute, click that attribute’s name. When an attribute is selected, the icons
in a plot are colored with that attribute’s color scheme.

To add a new attribute, click the cell labeled <new>.
To change where an attribute appears, drag the attribute name to new location.
To rename an attribute, double-click its attribute name.

To hide an attribute in a case table, select the attribute by clicking it, then choose Hide
Attribute from the Table menu; to display hidden attributes, choose Show Hidden Attributes from
the Table menu.

To delete an attribute, click it once to select it, then choose Delete Attribute from the Edit
menu.

To insert an attribute in a particular place, select the attribute to the right of that place,
then choose New Attribute from the Data menu.

Edit the formula of an attribute by double-clicking the current formula in the Formula
column.

Cases in Case Tables

To select and highlight a case, click its row number.
To enter data for a new case, go to the last row in the table and enter values for the case.
To edit data for a case, click the appropriate cell and enter the new value.

To delete a case, select it by clicking its row, then choose Delete Case from the Edit menu.
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Plots

Use plots to organize your data graphically to search for interesting patterns or group differences.

Here we mention some of the more general things you can do in plots. See Working with Plots
for more detailed information.
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e Click an icon to select it. This will also bring that case’s data card to the top of the stack
and will highlight that case in a case table or in another plot.

e To remove everything from a plot and start over, click the Mix-up button on the toolbar on
the bottom of the plot.

e Improve the appearance of a plot by resizing it (drag a corner) or by resizing the plot icons
(adjust slider on lower controls).

e To add an attribute to one of the plots’ axes, drag the attribute name from a data card, a
case table, or another plot and drop it on either of the axes.

e For numeric attributes, drag any icon to the right (or up) to make up to eight bins. To

make fewer bins, drag an icon to the left (or down).

e Drag a bin line of a numeric attribute to the left (or down) to make more, narrower bins.

Drag to the right (or up) to make fewer, wider bins.

e For category attributes, drag a case in any direction to separate out all cases with that value
from the rest of the cases.

e Choose one of several icon types from the Icon Type menu on the lower plot toolbar.

e Double-click on either endpoint of an axis to change that endpoint and/or the bin width.
To restore the default axis values, redrag the attribute from the data cards onto the axis.

e Some plot features, such as dividers and hat plots, only appear on fully separated
plots—plots that have no bin divisions and a continuous, numberline axis.

e Choose Swap Axes from the Plot menu to switch the attribute on the vertical axis with the
attribute on the horizontal axis.

e To remove attribute colors from the plot icons, click the light blue bar in the upper left of
the data cards.

TinkerPlots Help
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To prevent a plot’s color from changing, select the plot and click the Key button on the
upper plot toolbar. Close its lock by clicking it.

Choose Hide Selected Cases from the Plot menu to remove highlighted cases from the plot.
You can use this multiple times to exclude more and more cases.

Sliders

Sliders are explained in Working with Sliders.

Text

Text boxes are useful for documenting your work. You can put a text box next to a plot to serve
as a caption or short description of what the plot says. There’s no limit to how much you can
write in a text box. See the demonstration document Backpack Report.tp for an example of how you
can use text boxes and other TinkerPlots objects to make a project report.

To format text, go to the Text menu, where you can choose text font, size, and style, or choose
Show Text Palette, which gives you all these options and more. In Windows, the text palette appears
docked, on the bottom of the screen; on the Macintosh, it floats.

[=]

Geneva "HEI ""|- "| B | ) | 1) |X,,']t...|

Use the rightmost button on the text palette to expand it to show special symbols and formatting

tools.

Clicking a button places the special character in the cursor insertion spot.

Pictures

You cannot make drawings in TinkerPlots, but you can paste in pictures. If you are writing your
report in TinkerPlots, this is a good way to include useful illustrations and photos.

1.
2.

3.

In some other application, copy a picture onto your clipboard.

Make sure that nothing is selected in your document. (Click in an empty area to deselect

all objects.)

Choose Paste Picture from the Edit menu.

You can resize the picture just as you would any other object in TinkerPlots by dragging the

edges

of its frame.

You can also copy and paste pictures of TinkerPlots objects into a TinkerPlots document (for
example, if you want several, static graphs that can’t be changed).

1. Select the object.
2. Choose Copy Picture from the Edit menu.
3. Click in an empty area of the TinkerPlots document (to deselect all objects).
4. Choose Paste Picture from the Edit menu.
TinkerPlots Help 87
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Operators and Functions in the Formula Editor

Here are the operations and functions currently supported in the TinkerPlots formula editor.
Because many of these are inherited from Fathom, they may not be very useful in middle school.
However, because it’s very hard to predict when one might come in handy, we chose to leave
most of them in TinkerPlots.

Operators

e Arithmetic operators: +, -, *, /, » (Shift+6), !
These obey normal algebraic precedence, but you can use parentheses when in doubt. The
A operator raises to a power, and the ! operator computes the factorial of a number.

e Logical operators: and, or, not
Click the keypad buttons on the screen to enter these. (You can type these operators if you
are careful about using parentheses.)

o Comparison operators: <, >, =, #
These are available on the keypad. You can also type <, >, or = from the computer keyboard.
To type #, press Ctrl (Win) Option (Mac) and type =.

e Comparison operators: <, 2
Enter these by pressing Ctrl+Shift (Win) Option+Shift (Mac) while typing > or <, or by pressing
Ctrl (Win) Option (Mac) while clicking the buttons on the on-screen keypad.

Arithmetic Functions

abs Use either the function, as in abs(first — second), or use the vertical bar
button, | on the keypad, or press the | key on your computer keyboard.

combinations Returns the number of combinations of 7 things taken 4 at a time. For
example, combinations(5,2) is 10.

exp Exponential function (“e-to-the . . .”).

Sfloor Truncates to the next integer toward zero.

In Natural logarithm.

log Common (base-10) logarithm.

modulo Returns the remainder after one number is divided by another; modulo(11,
4) returns 3.

round By default, rounds to the nearest integer. round(ArtributeX, 2) rounds values
of AttributeX to the nearest hundredth.

sgn Signum function (+1 if the number is greater than 0; —1 if it’s less than 0; 0
ific’s 0).

sqrt Gives the square root of its numeric argument.

trunc Truncates, that is, lops off the decimals.

Conditionals

if Creates an “if” block. If the expression in parentheses after ifis true, the formula

returns the upper value; if not, it returns the lower. The example below returns
“big” if the value for xx is greater than 2 and “small” otherwise.

if ¢ length > 2} {:gﬂ;“..
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switch

Acts like a sophisticated 7f; and is very useful for recoding attributes. It takes an
optional expression inside parentheses and then evaluates each of any number of
true/false expressions to determine which value to return. This is best shown
with a couple of examples.

TinkerPlots interprets the following expression by substituting age for ? in each
of the expressions, starting at the top, until it finds one that is true. It returns the
value to the right of the colon for that expression. So, if age is 45, the value of the
entire expression is “mature.”

(?< &y infant'

(7 132 "child"

(7?20 “teen”

(¥ 307 "“young aduolt!

(7 < S0V "rnature"

else Mg e

switch [age)

Here’s another example, one that might be used to recode numeric data into
meaningful phrases. TinkerPlots compares the value of eduCode with each of the
numbers in parentheses and returns the expression to the right of the first one
that matches. If none match, it returns the value of the expression to the right of
else.

(1 :"High school”

(1) "Bachelor's degreeg”
(15 :"mMaster's degreg"
glse :"Saomething else”

switch (eduCode)

Distribution Functions

These functions, not described here, give you access to various statistical distributions. They are
not currently of much use in TinkerPlots but may be useful in future versions. You can access
brief descriptions of each by clicking a function’s name in the formula editor. Help text appears
in the Help pane at the bottom of the formula editor.

Logical Functions

evern

exists

includes

inRange

isNumber

odd

TinkerPlots Help

Returns true if the argument is even: even(10) returns true; even(11) returns
false. If the argument is not an integer, you will get a ZDOMAIN# error.

True if the value exists for the indicated attribute. For example,
exists(pressure) will be true for each case for which there is a value for
pressure.

Returns true if the second argument is a substring of the first (also treated as
» «s )’)

a string): includes(“the”, “he”) returns true; includes(“dancing”, “joy
returns false; 7ncludes(1234, 23) returns true.

True when a number is in a given range. For example, inRange(height, 60,
66) will be true for people whose height is greater than or equal to 60 and
less than 66. If the third argument is less than or equal to the second
argument, you will get an error.

True if the value is numeric. For example, isNumber(date) will be true for
the value “27” but false for the value “June.”

Returns true if the argument is odd: 0dd(15) returns true; 0dd(20) returns
false. If the argument is not an integer, you will get an error.
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Trigonometric Functions

All of the trigonometric functions you could want are here, plus hyperbolic functions and their
inverses. They all use radians.

sin, cos, . . .
asin, acos, . . .

sinh, cosh, . . .

You also get zan, sec, csc, and cot.
Inverse trigonometric functions. You also get azan, asec, acsc, and acot.

The other hyperbolic functions and their inverses are constructed the same
way: by adding an / to the end of the name. These hyperbolic functions and
their inverses are not in the list of trigonometric functions, so you must type
them from the keyboard.

Random Functions

random()
random(max)
random(min, max)

randomInteger(min,
max)

randomPick(al, a2, . . .)

randomBinomial(n, p)
n = number of trials

p = probability of success
randomNormal(mu, sd)

mu = the mean
sd = standard deviation

random Geometric(p)

mu = the probability of a
“catch.” Must be
between 0 and 1.

randomExponential(mu)
mu = the mean. Must be
positive.

A random number between 0 and 1.
A random (real) number between 0 and max.
A random (real) number between min and max.

A random integer between its two arguments, /nclusive. For example,
randomlInteger(1, 6) gives 1, 2, 3, 4, 5, or 6, chosen at random.

This function gives you an element randomly chosen from a list of any
number of arguments. For example:

randomPick(1, 2, 3, 4, 5, 6) makes a die.
randomPick(“heads”, “tails”) makes a coin.

randomPick(“Male”, Male”, “Female”) gives you a population that is two-
thirds “Male.”

This function gives you a random integer from a binomial distribution. For
example, randomBinomial(20, 0.5) gives the number of heads in 20 tosses of
a fair coin.

A random real number pulled from a normal distribution. For example,
randomNormal(0, 1) gives you a number from a distribution with a mean of
0 and a standard deviation of 1.

A random nonnegative integer from a geometric distribution. You can think
of the result as the number of turns it takes before you “catch” the case if the
probability of catching it is the argument. Catching on the first try yields 0.

A random real number greater than 0, pulled from a distribution that
declines exponentially (so there are more near 0, just as in the geometric
distribution). The larger the argument, the shallower the curve. Some
people use the reciprocal of 7u as the argument of their exponential
distributions.

Other Random Number Functions

TinkerPlots has a number of less commonly encountered random number functions, each of
which returns numbers from a different distribution. These include randomBeta, random Cauchy,
randomChiSquare, randomF, randomGamma, randomLattice, randomPoisson, and randomT. The
help text that appears at the bottom of the formula editor will provide some guidance for using

these functions.

TinkerPlots Help
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Text Functions

beginsWith Takes two arguments and returns true if the first begins with the second. For
example, beginsWith(LastName, “Mc”) will return true for “McBride,” false for
“Binker.”

concat Takes up to ten arguments and returns a string. For example, if a case has the

value “Denise” for the attribute Name, and the value “likes dogs” for the
attribute Hobby, then concat(Name, “ ”, Hobby) gives “Denise likes dogs.” The
arguments can be numeric or strings. You have to include an argument for the
space to get a space in the caption.

endsWith Takes two arguments and returns true if the first ends with the second. For
example, endsWith(LastName, “er”) returns true for “Binker,” false for
<« . »
McBride.
includes Takes two arguments and returns true if the second argument is a substring of

the first (also treated as a string). includes(“the”, “he”) returns true.

. « . » «s » g .

includes(“dancing”, “joy”) returns false. includes(1234, 23) returns true.
g Joy

stringLength Returns the number of characters for each case in the specified attribute.

stringToNumber ~ Returns the first number in a value. For example, suppose you have dinosaur
weights, but the values include the units, such as “14kg.”
stringToNumber(DinoWt) will return “14” for that case. TinkerPlots will then
treat the recoded attribute as numeric (very handy for cleaning up imported

data).

Statistics Functions

One Attribute

count Returns the number of cases for which the expression is true. For example,
count(NumberOfPets > 0) will return the number of cases for which
NumberOfPers is greater than zero. Similarly, count(exists(Gender)) will return the
number of cases for which the attribute Gender is defined. count( ) returns the
number of cases in the collection. For an attribute whose values are #rue and false,
count will return the number of cases for which the value is #rue.

first Returns the first value in the data set for the given attribute; for example,
first(height) would be 61 for a collection of people in which the first person’s
height is 61 inches.

iqr Interquartile range, for example, igr(blood_pressure). This function returns the
value at the 75th percentile minus the value at the 25th percentile.

last Returns the last value in the collection for the given attribute; for example,
last(name) would be Zelda for a collection of ducks in which the last duck’s
name is Zelda.

max Maximum value; for example, max(age).

mean The arithmetic mean; for example mean(height).

median The median; for example, median(speed).

min Minimum value; for example, min(salary).

percentile Returns the value with a given percentile. For example, percentile(50, speed) is

another way to compute the median. Or percentile(95, score) will return the score
corresponding to the 95th percentile.

popStdDev The standard deviation of the attribute you give it. This is the “population
standard deviation.”
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popVariance

proportion

QI
Q3
sampleStdDev

sampleVariance

stdDev

stdError

sum

uniqueValues

variance

The variance of the values. This is also popStdDev squared.

Gives the proportion of cases for which the argument is true. For example, if 12
out of 24 people are over 12 years old, proportion(age > 12) will yield 0.5.

The value that lies at the 25th percentile; for example, the first quartile.

The value that lies at the 75th percentile; for example, the third quartile.

Computes the sample standard deviation according to the formula
DIPHEES HHE S

q —\2

N e I | .

\;‘ 2—1 It is an unbiased estimate of the population standard deviation.
| n —

For example, sampleStdDev(pressure) computes the sample standard deviation of

the attribute pressure.

Computes the square of the sample standard deviation according to the formula

N2

X—X

2% For example, sampleVariance(voltage) computes the sample
n —

variance of the attribute voltage.

Standard deviation; for example, stdDev(score). Computes the standard deviation

c —\2
| X—X
of the cases in the collection using the formula \w E (Cant )
‘ n

Returns the standard error; for example, stdError(score). The formula that is used

.S . .. .

is —— where s is the sample standard deviation and 7 is the number of cases.
\n

Returns the sum of the values over all the cases. For example,

sum(time)l count(isNumber(time)) is another way to compute the mean of the

attribute time.

The number of unique values that an attribute has in the data set. For example,
uniqueValues(sex) will be 2 if there are only two values (“male” and “female”) for
sex. (Missing values are ignored.)

Computes the variance of an attribute, that is, the square of the standard

=\2
- , (x—Xx) .
deviation, according to the formulaz—. For example, variance(before —
n

after) computes the variance of the difference of the two attributes before and

after.

Transformations

bin

next

popZLScore

TinkerPlots Help

Takes the form bin(a, bin, min, max) where a = attribute, 6in = bin width, min =
start of bin 1, and max = end. bin gives you a string (category value) for a (its
“bin” as defined by the other arguments). For example, in(3.14, 2, 0, 10) gives
“b02” because the value (3.14) is in bin 2 in [0, 10] with bins of width 2. (The
last two arguments are optional.)

The value for the next case. If this is the last case, nexz returns 0. For example,
next(year) returns, for each case, the value of the next year. As with prev, next
takes an optional second argument that specifies the value to be returned for the
last case.

Returns the number of population standard deviations a value is from the mean.
For example, popZScore(finalExam) computes a standard score for each value of
the attribute finalExam.
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prev

rank

runLength(flip)

sampleZScore

uniqueRank

zScore

Two Attributes

correlation

covariance

linRegrintercept
linRegrSlope

rSquared

The value for the previous case. If this is the first case, prev returns 0. For
example, prev(year) returns, for each case, the value of the previous year. An
optional second argument allows you to specify the value prev should take if
there is no previous case. For example, prev(Factor, 1) will return the previous
value of Factor for all cases except the first, for which it returns 1.

Returns the position of the value when cases are ordered from lowest to highest.
For example, rank(Population) used as an attribute in a collection of states assigns
to each state its rank according to population. Note that if there are duplicate
values, the rank will be fractional and the same for all the values. See also
uniqueRank.

This one’s wild! It gives the number of identical values immediately prior to and
including the current value. For example, if flip contained {H, H, H, T, H, T,
T}, this example would return {1, 2, 3, 1, 1, 1, 2}. You can use
max(runLength(flip)) to compute the longest streak of heads or tails in a coin-
flipping simulation.

Returns the number of sample standard deviations a value is from the mean. For
example, sampleZScore(height) computes a standard score for each value of the
attribute hbeight.

Returns the unique position of a value in a list of values sorted from smallest to
largest. Each value in the list gets assigned a different rank, even if there are
duplicate values. For example, if the attribute /V contains the values {1, 2, 3, 2},
an attribute using the expression unigueRank(N) will have values {1, 2, 4, 3}. See
also rank.

Same as sampleZScore.

Returns the correlation coefficient for two continuous attributes. For example,
correlation(stories, height) will return the correlation coefficient for szories and
height. This value will be between —1 and +1 and is a measure of how closely the
values of one attribute follow those of the other.

Returns the average of the products of the deviations of each of two attributes
from the mean. For example, covariance(hp, mpg)/variance(hp) would give the
slope of the least-squares regression line for /4p versus mpg.

Returns the intercept of the least-squares regression line with x as the
independent attribute and y as the dependent attribute.

Returns the slope of the least-squares regression line with x as the independent
attribute and y as the dependent attribute.

The square of the correlation coefficient for two attributes. rsguared(x;, y)
represents the proportion of the variation of y that is accounted for by the
variation in x. It takes on values between 0 and 1.

Expressing Qualifiers in Statistics Functions

caselndex

Jalse

T

true

TinkerPlots Help

A value equivalent to the “row number.” No parentheses are needed. This is the
order in the collection, not the order you see in a sorted case table.

A constant whose value is always false.

You can enter the value for 7 by typing pi or by double-clicking the entry for pi
under Special in the function list.

A constant whose value is always true.
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In the Menus

Here is a list of the TinkerPlots menus and what is in them. If a command is followed by
“(Win),” it appears in another menu on the Macintosh (and vice versa.) If a command is
followed by “(Win only),” it is not available on the Macintosh. Some commands have keyboard
shortcuts, which can be found beside the command in the menu. You can find additional useful
shortcuts in Keyboard Shortcuts.

Most objects also have a contextual menu, containing commands you might need while working

with that object. To access these menus, select the object and right-click (Win) or press Control
and click (Mac).

TinkerPlots (Macintosh only)

Use the TinkerPlots menu to hide or quit TinkerPlots and to set preferences. Some commands in
this menu are available in other menus in Windows, as noted.

About TinkerPlots
Preferences... a8,

Services [

Hide TinkerPlots
Hide Others HH
Show All

Quit TinkerPlots 3#Q

About TinkerPlots Displays basic information about TinkerPlots, including the version
you are using. (In Windows, this is in the Help menu.)

Preferences Allows you to use large fonts in TinkerPlots objects and to turn
sound off. (In Windows, this is in the Edit menu.)

Services Allows you to choose from other Macintosh services.

Hide TinkerPlots Removes TinkerPlots from your screen without closing it.

Hide Others Removes all open applications except TinkerPlots from your screen
without closing them.

Show All Shows all open applications and windows.

Quit TinkerPlots Quits the program. (In Windows, this is in the File menu.)

File
Use the File menu to open, import, save, and print files. This is how the File menu appears in

Windows:

Mew Chrl+M

Qpen, .. Chrl+0
Close Chrl-+
Save Chrl+3

Save s,

Impatt From File. ..
Irnport Franm Url. .

Shioww Page Breaks

Prink Setup. ..

Prink Presvigwm

Prink. .. Chrl+P

Exit

TinkerPlots Help
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New Brings up a new, blank TinkerPlots document.
Open Opens an existing TinkerPlots document.

Close Closes the current document. This is the same as clicking the close
box on the window. If the document has not been saved,
TinkerPlots prompts you to save it.

Save Saves the document. If it has been saved before, TinkerPlots updates
the file to the current state. If the document hasn’t been saved
before, TinkerPlots asks you to give it a name and specify where to

save it.

Save As Saves the document, but allows you to give it a new name and
specify where to save it (thus preserving the previously saved file).

Import From File Imports data from a text file. You enter the name of the file in the
dialog box that appears.

Import From Url Imports data from the Internet. You enter the URL, and
TinkerPlots imports the data.

Print Setup (Win) Chooses a printer, page size, and so forth.

Page Setup (Mac)

Show Page Breaks Shows where page breaks will occur when the document is printed.
This is useful if you want everything to appear on one page, for
instance.

Print Preview (Winonly)  Shows what your document will look like printed.

Print Prints your document. In the dialog box you say how many copies
you want, the page numbers to print, and so forth.

Exit (Win) Quits the program. (On the Macintosh, this is in the TinkerPlots
menu.)

Edit

The Edit menu controls the clipboard, undoing, editing, and preferences. The specific names of
some menu items change to reflect the object selected. This is how the Edit menu appears on the
Macintosh:

Undo New Data Cards #Z

Undo (Action) Undoes the last thing you did. The menu name shows the last
action (such as Undo Typing). TinkerPlots has unlimited undo.
Redo (Action) Redoes the last action you undid.

TinkerPlots Help
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Cut Case or Cut Attribute

or Cut Text

Copy

Paste

Delete Case or Delete
Attribute or Delete Text

Select All
Delete (Object)
Hide (Object)

Show Hidden Objects
Duplicate (Object)

Edit Formula

Cut Formula
Copy Formula

Paste Formula

Clear Formula

Preferences (Win)

Data

The Data menu controls new cases, renaming attributes, and locking a dataset to prevent it from

Cuts what is selected and puts it on the clipboard. You can cut text
from text boxes, data cards, or case tables. You can also cut cases or
attributes from data cards or case tables.

Places a copy of what you’ve selected into the clipboard. If you
select and copy an object (such as a plot or case table), TinkerPlots
copies it as a picture. This is one way to take a snapshot of a graph
to put into another application.

Pastes what is on the clipboard into the location you have selected.
If the clipboard contains text, Paste replaces selected text or inserts
the text at the insertion point. If the clipboard contains cases, Paste
adds those cases to the selected stack of data cards.

Deletes the case, attribute, or text you have selected.

Selects all cases in a stack of data cards or case table; selects all text
in a text box.

Deletes the selected object. Use this to eliminate unwanted objects
such as data cards, plots, text boxes, and so forth.

Hides the selected object from view. It does not eliminate any of the
selected objects from the document.

Unhides any hidden objects in the document.

Makes an exact copy of the selected object and places it in the
document. This is especially useful for making a duplicate of a plot.

Brings up the formula editor for the selected attribute (same as
double-clicking in the attribute’s formula cell in a data card or case

table).

Cuts the formula from the selected attribute in the data card or case

table.

Copies the formula of the selected attribute in the data card or case
table and places the formula in the clipboard.

Pastes the formula in the clipboard into the selected attribute. This
is perfect for avoiding retyping a complex formula: copy it from one
attribute and paste it into another.

Removes the formula from the selected attribute. The values of the

actribute will remain, but they will now be the same as if you’d
entered them individually without a formula.

Allows you to use large fonts in TinkerPlots objects and to turn
sound off. (On the Macintosh, this is in the TinkerPlots menu.)

being changed. This is how the Data menu appears in Windows:
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Mew Zases. .,
Mew Attribute. ..

Rename Attribute. ..
Formak Attribute, ..
Reset Attribute Color

Lock Collection
Rename Collection. ..
Export Colleckion,..
Rewvert Callection, ..

Rerandomize

Chrl+

New Cases
New Attribute

Rename Attribute
Format Attribute

Reset Attribute Color

Lock/Unlock Collection

Rename Collection
Export Collection

Revert Collection

Rerandomize

Plot

The Plot menu controls axes, filters, hides cases, and lets you customize the plot toolbars. To see

Adds new cases to your data set. You specify how many.

Adds a new attribute to your data set. If an attribute is selected in a
case table, the new attribute is placed to the left of the one selected.

Changes an attribute’s name (same as double-clicking its name).

Changes how numbers are formatted into scientific or engineering
notation. You specify the number of significant digits displayed.

If you have changed the color scheme of one or more attributes in
the data cards, this restores the original attribute colors.

Locks the collection to prevent changes to the data. You can still
analyze the data, but you can’t edit values, add new cases, make new
attributes, rename them, and so forth. Unlock to allow changes to the
data.

Allows you to change a collection’s name (same as double-clicking
its name).

Exports data from the selected stack of data cards to a tab-delimited
text file.

Restores the data in the selected stack of data cards to how they
were when you last saved. If you’ve changed one or more data
values, this is a quick way to undo these changes. This does not
delete or change plots or other objects you may have added.

Generates new random values for values created using a random
function.

the Plot menu, select a plot. This is how the Plot menu appears on the Macintosh:

Mix Up
Remix
Swap Axes

<}

Show Hiddetl
Add Filter

{r3EM
£
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Show Connecting Lines

Toolbars
Options
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Mix Up Returns a plot to its original, disorganized state. This is the same as
pressing the Mix-up button on the lower plot toolbar.

Remix Remixes unstacked cases within a bin.

Swap Axes Swaps the attributes on the horizontal and vertical axes. If only one
attribute is plotted, it will move to the other axis.

Hide Selected Cases Hides cases that are selected in the plot.

Hide Unselected Cases  Hides cases that are not selected in the plot.

Show Hidden Cases Unhides any cases that are hidden in the plot.

Add Filter Adds a filter to the plot. If there is no current filter formula, the

formula editor will appear. You enter a formula that specifies the
cases to keep in the plot.

Show Connecting Lines Connects the cases in a plot with a line according to case order. This
is useful with graphs of data that were entered according to time or
in some other particular order.

Toolbars Allows you to remove the upper or lower plot toolbars entirely or to
remove particular buttons from the toolbars.

Options Allows you to show/hide attribute units, change bin styles, modify
the Drag Value tool, and stack by case order.

Text

The Text menu controls font, size, and style of text in a text box. To see the Text menu, select a
text box.

Text Font L
Texk Size L
Text Skyle k
Show Text Palette
Text Font Specify font for selected text.
Text Size Specify font sizes for selected text.
Text Style Specify style (plain, bold, italic, underline) for selected text.
Show Text Palette Brings up a text palette for setting font, size, style and for inserting

special symbols and characters. In Windows, the palette appears
docked at the bottom of the screen; on the Macintosh, it floats.

Table

The Table menu controls attribute and formula display, sorts the data in the table, and adds filters
to case tables. To see the Table menu, select a case table. This is how the Table menu appears in

Windows:

Show Formulas

Hide Attribuke

Show Hidden attributes
Sort Ascending

Sort Descending

&dd Filker _krl+F
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Show Formulas Displays attribute formula row for viewing and editing of attribute
formulas.

Hide Attribute Hides the selected columns (attributes). The attributes will still
appear in the data cards.

Show Hidden Attributes  Unhides any hidden attribute in a case table.

Sort Ascending Sorts cases in case table in ascending order of selected attribute from
smallest to largest.

Sort Descending Sorts cases in case table in descending order of selected attribute
from largest to smallest.

Add Filter Adds a filter to the case table. If there is no current filter formula,
the formula editor will appear. You enter a formula that specifies the
cases to keep in the case table.

Window

Use the Window menu to choose among the current windows and to open objects in a floating
window. This is how the Window menu appears in Windows:

Cascade
Wi in Window Al

v 1 Documentl

Cascade (Win only) Lays out the windows so that you can see all their title bars.

View In Window Opens the selected object in its own floating window.

(names) Select the open TinkerPlots document that you want to bring to the
top.

Help

Use the Help menu to find out how to accomplish particular tasks in TinkerPlots, to access
tutorial movies, and to access online resources. This is how the Help menu appears in Windows:

TinkerPlots Help
TinkerPloks Movies

Online Resource Center
Check For Updates

about TinkerPloks

TinkerPlots Help Brings up the TinkerPlots Help system in your browser (but does not
connect you to the Internet).

TinkerPlots Movies Allows you to access movies giving instruction about various features
of TinkerPlots. This opens your browser but does not connect you to
the Internet.

Online Resource Center  Takes you to a Web site where you can get more data sets and
activities, share your own data, and get other resources.

Check for Updates Takes you to a Web site where you can check if you have the most
recent version of TinkerPlots, and download an update if not.

About TinkerPlots (Win)  Displays basic information about TinkerPlots, including the version
you are using. (On the Macintosh, this is in the TinkerPlots menu.)

TinkerPlots Help
© 2005 University of Massachusetts



Keyboard Shortcuts

Keyboard shortcuts for menu commands are listed to the command in the menu. Here are

additional useful keyboard shortcuts:

Operating on Data in Plots

Action

Increase icon size
Decrease icon size
Slow animation

Order descending

Use Drag Value/Add
Case/Drawing Tool
multiple times

Reposition cases while
an attribute is selected

Windows
+
Space

Shift+Order
Vertical/Horizontal

Alt+tool

Press Alt while
dragging case icons.

Macintosh
+
Space

Shift+Order
Vertical/Horizontal

Option+tool

Press Option while
dragging case icons.

Moving Around in Data Cards and Case Tables

Action

Go to first case

Go to last case

Go to next case

Go to previous case
Move to next value/cell

Move to previous
value/cell

Windows
Home

End

Page Down
Page Up
Tab
Shift+Tab

Macintosh
Home

End

Page Down
Page Up

Tab
Shift+Tab

For Fathom Users: Show Fathom Collection Object

1. Press and hold Ctrl+Alt (Win) Command+Option (Mac). Macintosh users can also click

anywhere in the document.

Click in a blank area in the document (required on Mac only).

3. From the Edit menu, choose Show Hidden Objects.
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add midrange, 46

attributes, 20 mode, 46
cases, 25 axes
dividers, 42 adjust, 35
reference lines, 41 change axes endpoints, 35
animation, 52 change bin widths, 35
attributes, 10 return to default axes, 36
add, 20 reverse axis endpoints, 36
in case table, 20 read values with a reference line, 42
in data cards, 20 remove an attribute, 33
category, 10 replace an attribute, 33
change color of, 22 separate, 42
change position of, 21 swap, 34
in case table, 22 bins, 11
in data cards, 21 adjust widths, 35
color bar, 10 change number of category bins, 34
define units of, 21 change number of numeric bins, 34
display units, 34 continuous-style, 37
delete, 21 reorder category bins, 36
edit or delete formulas for, 23 Boolean expressions, 68
in case table, 23 case icons, 37
in data cards, 23 borderless, 39
enter or change value, 24 change size of, 37
in case table, 24 using Shift/+ and Shift/—, 38
in data cards, 24 using the icon size slider, 37
formula-defined, 64 using the icon/tool Options menu, 37
common uses of, 70 invisible, 39
convert measurement units, 70 labels for, 38
copy and paste, 68 reposition, 39
create derived attributes, 70 in a binned plot, 40
create realistic data, 74 in a mixed-up plot, 39
if-statements, 68 in any plot, 40
in case tables, 65 types of, 38
in data cards, 64 circle icon, 38
make Boolean expressions, 68 fuse circular, 39
recode missing values, 71 fuse rectangular, 39
recode numeric values to categories, 70 image icon, 39
round data, 71 square icon, 39
switch statements, 69 value bar horizontal, 39
transform time-coded data, 72 value bar vertical, 39
fully separated, 11 cases, 10
hide, 21 add, 25
numeric, 10 in a plot, 26
plot two, 33 in case table, 25
remove from an axis, 33 in data cards, 25
rename, 21 change data values, 49
replace on an axis, 33 connecting lines, 48
rules for naming, 20 counts and percents, 44
selected, 10 cell percents, 46
show, 21 column percents, 45
averages, 46 row percents, 45
display values, 47 delete, 26
mean, 46 excluded, 11
median, 46 filter, 49
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hide, 49 reference lines, 41

highlight, 48 dividers, 42
select add, 42
in a plot, 27 add several, 43
in case table, 27 equal count, 43
sort, 26 equal width, 43
view data, 26 remove, 42
collections, 10 reposition, 43
combine, 27 split, 43
image icons in, 40 unsplit, 43
import data. See data documents, 15
lock, 28 create a new, 15
make new, 17 duplicate objects in, 16
rename, 28 Fathom, 17
revert to last saved, 28 open, 13
color parts of, 15
change attribute color, 48 place objects in, 15
color key, 47 redo, 14
lock plot color, 47 save, 14
color bar, 10 undo, 14
conditionals, 88 edit
copy attribute formula, 23
data, 18 axes, 35
documents, 14 filters, 49
image icons, 41 image icon, 40
into other applications, 62 values, 51
objects, 16 Edit menu, 95
plots, 51 Clear Formula, 96
data Copy, 96
copy, 18 Copy Formula, 96
create, 28 cut attribute, 96
enter into case table, 17 cut case, 96
enter into data cards, 17 Cut Formula, 96
export, 20 Cut text, 96
import from a text file, 18 Delete, 96
import from the Internet, 19 Delete attribute, 96
paste, 18 Delete case, 96
recode, 28 Delete text, 96
subsets of, 28 Duplicate, 96
Data menu, 96 Edit Formula, 96
Export Collection, 97 Hide, 96
Format Attribute, 97 Paste, 96
Lock/Unlock Collection, 97 Paste Formula, 96
New Attribute, 97 Preferences, 96
New Cases, 97 Redo, 95
Rename attribute, 97 Select all, 96
Rename Collection, 97 Show Hidden Objects, 96
Rerandomize, 97 Undo, 95
Reset Attribute Color, 97 Fathom
Revert collection, 97 open documents, 17
delete relationship to TinkerPlots, 9
attribute formulas, 23 show Fathom collection object, 100
attributes, 21 File menu, 94
cases, 26 Close, 95
dividers, 42 Exit, 95
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Import From File, 95
Import From Url, 95
New, 95
Open, 95
Page Setup, 95
Print, 95
Print Preview, 95
Save, 95
Save as, 95
Show Page Breaks, 95
formulas, 64
adjust the formula editor panes, 66
apply the formula, 66
attribute and function list, 67
attribute defined by, 64
copy and paste, 68
edit or delete, 23
enter a formula, 65
move the cursor and select a portion of an
expression, 67
to filter a plot, 65
use formula editor, 64
use the keypad, 66
frequency tables, 61
functions
arithmetic, 88
distribution, 89
logical, 89
random, 90
statistics, 91
one attribute, 91
transformations, 92
text, 91
trigonometric, 90
graphs
binned scatter plot, 58
dot map, 59
dot plot, 53
frequency bar graph, 54
histogram, 54
pie graph, 56
rectangle graph, 56
scatter plot, 57
stacked dot plot, 53
stacked value bar graph, 55
time series graph, 58
value bar graph, 55
Help menu, 99
About TinkerPlots, 99
Check for Updates, 99
Online Resource Center, 99
TinkerPlots Help, 99
TinkerPlots movies, 99
icons. See case icons or image icons.
if-statements, 68
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image icons, 40

change image of, 40
copy, 41
create, 40

import, 18

data by copy and paste, 18
data from a text file, 18
data from the Internet, 19

install

on a network, 13
on each computer, 13
on the server, 13

keyboard shortcuts, 100

for data in plots, 100
in data cards and case tables, 100

movies, 99

objects, 83

case tables, 84
attributes, 85
cases, 85

data cards, 83
attributes, 84
cases, 84

duplicate, 16

iconify, 16

move, 15

pictures, 87

place in documents, 15

plots, 86

resize, 15

sliders, 87

text boxes, 87

view in window, 16

operators, 88

arithmetic, 88
comparison, 88
logical, 88

pictures, 87

paste as image icons, 41
paste from other programs, 87

Plot menu, 97

Add Filter, 98

Hide Selcted Cases, 98
Hide Unselected Cases, 98
Mix-up, 98

Options, 98

Remix, 98

Show Connecting Lines, 98
Show Hidden Cases, 98
Swap Axes, 98

Toolbars, 98

plots, 29

basic operations in, 30
order, 31
separate, 32



stack, 30
box plot, 60
change toolbars, 52
draw on, 51
duplicate, 51
hat plot, 43
make new, 29
mix-up, 33
part of, 29
remove an attribute, 33
replace an attribute, 33

reference lines, 41

add, 41

read axis values, 42
remove, 41
reposition, 41

split, 42

unsplit, 42

reports, 62

copy into other applications, 62
enter text, 62
paste pictures, 62

sliders

animate, 76

change scale of, 75

change value of, 75

common uses
animate time series data, 77
create a random sample, 81
create realistic data, 82
grow a sample, 78

common uses of, 76

in formulas, 76

make, 75

rename, 75

restrict values of, 76

switch statements, 69
Table menu, 98
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Add Filter, 99
Hide Attribute, 99
Show Formulas, 99
Show Hidden Attributes, 99
Sort Ascending, 99
Sort Descending, 99
text
enter, 62
format, 87
Text menu, 98
Show Text Palette, 98
Text Font, 98
Text Size, 98
Text Style, 98
TinkerPlots menu, 94
About TinkerPlots, 94
Hide Others, 94
Hide TinkerPlots, 94
Preferences, 94
Quit TinkerPlots, 94
Services, 94
Show all, 94
units, 21
values, 10
change data values, 49
change number format, 24
default, 24
engineering notation, 25
fixed decimal, 25
scientific notation, 25
enter or change value, 24
in case table, 24
in data cards, 24
round, 24
Window menu, 99
Cascade, 99
View In Window, 99





